Katalon Studio 9.1 the web recorder has stopped working for me

Hi I seem to be here a lot these days,

I was assisted not so long ago with a coding issue (sorted) - anyway to cut a long story short I deleted my project while manually removing katalon during that process - I have since re-written the code back about halfway so no worries - I then re-installed version 9.1 and my manager at work said he doesn’t want it on github which was suggested by the previous guy who helped with the coding issue because I was an idiot and deleted my project and so I have put it on the company’s sharepoint and then a link to my company onedrive,

Katalon opens the project and even runs the test cases but the web recorder does not want to record any new steps even in newly created blank cases.

I then tried everything I could think of manual removal - I even went and searched the registry for Katalon and deleted everything - this is after multiple pc and application and web recorder restarts were done - nevermind the multiple re-installations.

I have since moved the project out of share point and into a onedrive sync folder so that it is one again actually on my machine - I rinsed and repeated all of the above - I have been at this all day (10 hours) and still trying to get the web recorder to work - it driving me nuts.

plugins are re-loaded - web drivers and chrome updated throuout all of the above

I have also gone back to the previous version of studio - the recorder just does not work anymore

I am at wits end - I really need some help, is there is anybody who is willing to tackle this one with me?

Thanking you in Advance, Derick (I don’t know how to change my name from katalon9)

1 Like

I hope the issue is not a bug with KS 9.1, however, when I was using the Web Spy last day, I was having occasional issues with it not “working”. What I remembered from years ago is that I had to click on the browser application sometimes without using the Web Spy to bring focus back to the application and then I could carry on. So, see if you can bring focus back to your application by clicking on it and see if it is just an issue with the recorder having lost focus.

Hi @grylion54 (Mike) thanks for your response - I did try that - I think there was just too much meesing around to make it work that I maybe messed it up properly

I have ended up re-doing my entire machine - as soon as I have katalon installed again and try the recorder - I will let you guys know.

Thank you.

ok - I have refreshed my PC - new windows installation - I have installed katalon 9.1 - The recorder is not working - it is not recornding any new steps - the recorder is dead.

the plugins are updated the webdrivers are updated - chrome web driver updated successfully to the cuurent version of chrome - the recorder is dead.

why does katalon force you to create a new project when all you want is to open your current one - thats stupid - what must you now do with that new project that you don’t want? go through the whole process of deleting it because its rubbish and not what you want

anyway - I am not going to waste my time trying to automate without the web recorder - so automations stops until I can download a version of Katalon the works with its recorder.

and management is just going to have to accept it because I don’t how to make the web recorder (Record) i.e do what it is suppoed to do. and if I seem angry its because I have been battling with this for three straight days now

and my company is never going to purchase the product if even the free version cannot be used as proof of concept.

I DO NOT want to look for alternatives - I Really want to give katalon a go before I have to start searching for someting else if this software is not going to work for me.

I would really appreciate it if somebody from Katalon itself could assist me because I would really like to become a paid client.

I know you don’t want to hear it but I only used the Web Recorder on my first couple of days. I couldn’t figure out how to get it to change my script, so I gave up on it. I do use the Web Spy so I can get some objects quickly, but then I spend a lot of time renaming them to my convention and deleting “trash” attributes within. What I do now is a LOT of copy and paste of my statements and then a LOT of drag and drop from the OR to the Script tab. It took me some time to get a naming system for my objects so that I use the correct object in the statements, but I think I am the better for it. Perhaps create yourself a template of commands and then copy and paste to create your Test Cases. If you are paid by the hour for productivity, then sitting waiting doesn’t seem efficient.

Hi @katalon9 ,

Does any previous version of Katalon Studio such as 8.6.8 or 9.0.0 work on your machines?

I’m surprised a man of your calibre goes anywhere near the OR.

#justsayin

Hi am trying to work around it by doing that and all of my test objects are maticulously named but - I am the only manual tester (only tester) at my company and I am very busy - I am trying to get automation going - so I kinda need the speed the web recorder provides, I do not spend all day in automation even though I would like to.

Hi 8.6.8 everything worked fine - then I had an issue and in the process of trying to sokve it and updating to 9.1 - the software stopped working properly - Then I refreshed windows on my machine - now 8.6.8 the recorder does not want to work.

but because I refreshed my PC and this keeps your files - I think that somewhere on this machine and something to do with Katalon is broken that I don’t know about to remove - because there does not seem to be a Katalon uninstaller.

I may need help to properly manually remove all katalon files and folders from the disk - so that there are no remnants of it and then - try again.

Can somebody help me to try that.

I think I have managed to remove katalon completely from the disk again - I have installed Katalon 9.1 started a brand new project and recorder still does not record

I will have to wait until Monday and try and get hold of Katalon for assistance.

@katalon9,

Can you share with me the error log file.
And please also share with me the location of Katalon Studio on your machine.

Hi Good Morning.

The location of katalon is C:\Users\Derickm.katalon\packages\Katalon_Studio_Windows_64-9.1.0\Katalon_Studio_Windows_64-9.1.0

and I do not know where the error log file is - there are a lot of file that look like they could be log files - please tell me where I can find it and I will gladly provide it. I have attached a file called .log found in a config folder I hope that is the one.
.log (188.3 KB)

You can get the error log via the main menu:

image

Here it is - and thank you.
.log (188.3 KB)

Hi @katalon9,

Does this happen with another AUT such as google on a blank test case?

java.lang.NullPointerException: Cannot invoke “com.kms.katalon.composer.testcase.ast.treetable.AstBuiltInKeywordTreeTableNode.getTestObjectText()” because “latestNode” is null
at com.kms.katalon.composer.webui.recorder.dialog.RecordedStepsView.beforeNodeAdded(RecordedStepsView.java:302)
at com.kms.katalon.composer.webui.recorder.dialog.RecordedStepsView.addNode(RecordedStepsView.java:255)
at com.kms.katalon.composer.webui.recorder.dialog.RecordedStepsView.addNewStep(RecordedStepsView.java:251)
at com.kms.katalon.composer.webui.recorder.dialog.RecorderDialog$26.run(RecorderDialog.java:2077)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:183)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:133)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4785)
at org.eclipse.e4.ui.workbench.swt.DisplayUISynchronize.syncExec(DisplayUISynchronize.java:34)

I saw this bug which happens when you add a new custom keyword in Recorder dialog. This issue will fix in v9.2.0.

I will test that quick and let you know - although I have tried it on the default sample heathcare application Katalon provides with no success - will check if I can record some of Google

ok I am confused - it worked the recorder is working and now when I go back to my project ahh the recorder is working again ??? I have no words - was it stuck somewhere somehow and doing that unstuck it. ???

Thank you very much for your guys assistance - the recorder is working again.