Katalon Runtime Engine w/ Jenkins - do we still use the Katalon plug-in for Jenkins?

Just grabbed some licenses for Katalon Runtime Engine. Failing to kick off a job using Runtime Engine with the Katalon plug-in. Is the plug-in still the preferred path for Jenkins configuration? Or should I only be using shell commands in Jenkins?

Specifying 7.0.5 as the Katalon version in the plug-in, with the following commandline arguments:

-testSuitePath=“Test Suites/Production/Page_Health_Check” -executionProfile=“default” -browserType=“Firefox” -apiKey=xxxxxxx -retryFailedTestCases=true -retry=2

/usr/bin/xvfb-run: line 181: /home/jenkins/.katalon/7.0.5/Katalon_Studio_Engine_Linux_64-7.0.5/katalon: No such file or directory
Build step ‘Execute Katalon Studio Tests’ marked build as failure
Finished: FAILURE

Appears to be looking for ‘katalon’ and not ‘katalonc’? What am I doing wrong here


had a strong feeling jenkins plugin has been forgoten from the migration to kse process …
/me grabbing popcorn

@ThanhTo at least any RE updated docker image with trial license is available?
as you know me already i am lazy to check, just asking …

1 Like

Please make sure Jenkins are running the latest version of this plugin.

1 Like


We tried to deploy the Jenkins plugin version 1.0.21 and it seems still try to run katalon and not katalonc. Any ideas how to resolve that.

/Niklas W

1 Like

I’m having issues in Jenkins running my job in Katalon 7.0.10, no matter if I add the runtime engine or not. If I run without the runtime I engine I get the message: “Starting from Katalon Studio version 7.0.0, please use the Katalon Studio Runtime Engine to execute Katalon Studio projects in console mode.” This windows batch command ran fine before upgrading to Katalon 7.0.10.
But when I have it set in the windows batch command set to use the runtime engine “katalonc…” I get a message: “‘katalonc’ is not recognized as an internal or external command”

Windows Batch Command: without runtime engine

Jenkins Output:

Windows Batch Command: with runtime engine

Jenkins Output:

Not sure what I am doing wrong here, but if anyone is available to help that would be awesome!