Katalon Plugin keywords are not coming under custom keywords


#1

Hello Team

I have 2 plugins installed in Katalon store [Gmail Read/write and PDF ] and on reload plugin in katalon both plugins shows up. See the screenshot below, but under the custom keyword there is no plugin keyword.
I already asked Gmail Plugin developer @Hari , he already updated the plugin to support latest version of Katalon but its not working. Can you guys help me to make this working?

Katalon version : 6.2.1
image


#2

Did you also got this error ?

36%20AM


#3

No, For me reloading the plugin works but there is no plugin keywords under Custom Keywords.


#4

I had a similar issue where I was also getting this error and no keyword was showing up under custom keywords. I would tag @huynguyen in this post as he helped me in getting the issue fixed.


#5

@haspreet.singh @manpreet.mukkar please send me error log ( you can find out at Help -> Error Log) and screenshot about custom keywords tree (see attach). It’ll help us investigate the issue.


#6

Hi Alice,

I have the same issue. Have privately sent the log to yourself.

Thanks.


#7

Hi @Alice Here is screenshot of the custom keywords tree and Sent you the error log in message. Please let me know if any further information is needed from my side.
Thanks in advance :slight_smile:


#8

@Manish6 @haspreet.singh we’re in time to investigate, the response will be displayed later
@haspreet.singh please grab and attach again the screenshot. Keyword Browser on the top left the screen, second icon (please see my attach).
Thank you so much


#9

Hi @Alice , I have found something interesting:

If I load an example project, i.e. this one https://github.com/katalon-studio-samples/katalon-jmeter-sample I get the following under custom keywords


If I then load my personal project, which I started a little while ago, from December 2018 (older build - but using the auto update feature built in) I lose those keywords even if I reload the plugins.
Katalon2
These are the plugins I have installed.
Katalon3


#10

@Manish6 How about Katalon Studio latest version (6.2.1) on website katalon.com? Grab and explore it then inform me the issue still having or not


#11

Yes 6.2.1 is doing the exact same thing as 6.2.0… I have tried reloading the plugins through the options.
Katalon4
Heres the log: KatalonLog.txt (135.2 KB)


#12

Just tried downloading a fresh copy and running that, but the same issue (previously I used the Katalon upgrade feature).


#13

@Alice Here is screenshot. Custom Keywords are empty.


#14

@Manish6 please delete this file katalon-dbms-keywords.jar in Plugins folder, then open the project and reload again


#15

Unfortunately both of my instances (6.2.1) does not have that .jar file


#16

In your project, not in Katalon Studio package


#17

there us no .jar file under plugins folder. See the screenshot


#18

Same for me


#19

I have also downloaded the Katalon-dbms-keywords.jar file from the git repository and manually placed it in the above folder. Then tried reloading plugins but the same issue.


#20

Hmmm, I think DBMS Keywords is a root cause. Can you uninstall this plugin and remove something relevant this plugin (file .jar in Plugins folder at Project)? Hope it can help you @Manish6