Katalon Basic Report Plugin - Proxy Setup Issue

I am currently facing an issue with Katalon 6.2.2 version, Can you please let me know on how to configure the proxy settings.

I was able to generate the Junit reports in my local without any proxy settings (No proxy) for the web app testing for Katalon demo page. But while I am using the proxy, I tried to configure the proxy settings in Katalon studio with “Manual proxy config” and also with “Use system config” settings ; tried to run with CLI and also with Jenkins. But I am getting error while reloading the plugin. I have installed Basic Report plugin in Katalon Studio.

I am mentioning the Jenkins build results and also error details below for your reference.

Jenkins Build Result with Manual proxy config settings:

C:\Katalon\Katalon_Studio_Windows_64-6.2.2>katalon -runMode=console -noSplash -consoleLog -projectPath="C:.… \Katalon Studio\reporttrial\reporttrial.prj" -apiKey= -***** -reportFolder=C:\ KatalonTest -reportFileName="report" -retry=0 -testSuitePath="Test Suites/TStrail" --config -proxy.option="MANUAL_CONFIG" -proxy.server.type="HTTP" -proxy.server.address= "http://proxy.***** " -proxy.server.port= "" -proxy.username=" " -proxy.password="******* -executionProfile="default" -browserType="Chrome"

C:\Users\qlh9gqq\Downloads\Katalon\Katalon_Studio_Windows_64-6.2.2>exit 0

Recording test results

ERROR: Step ‘Publish JUnit test result report’ failed: No test report files were found. Configuration error?

Finished: FAILURE

Jenkins Build Result:


C:\ Katalon\Katalon_Studio_Windows_64-6.2.2

C:\Katalon\Katalon_Studio_Windows_64-6.2.2>katalon -runMode=console -noSplash -consoleLog -projectPath="C:\Katalon Studio\reporttrial\reporttrial.prj" -apiKey=******* -reportFolder=C:.jenkins\workspace\KatalonTest -reportFileName="report" -retry=0 -testSuitePath="Test Suites/TStrail" -executionProfile="default" -browserType="Chrome"

C:\Katalon\Katalon_Studio_Windows_64-6.2.2>exit 0

Recording test results

ERROR: Step ‘Publish JUnit test result report’ failed: No test report files were found. Configuration error?

Finished: FAILURE

Below are the error details while I am using the proxy:

Error reloading plugins:

com.kms.katalon.plugin.models.ReloadPluginsException: Unexpected error occurs during executing reload plugins under account: username: —, endpoint: https://store.katalon.com/api/products/ks?appVersion=6.2.2

at com.kms.katalon.plugin.service.PluginService.reloadPlugins(PluginService.java:184)

at com.kms.katalon.composer.handlers.ReloadPluginsHandler$1.run(ReloadPluginsHandler.java:61)

at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Caused by: com.kms.katalon.plugin.models.KStoreClientExceptionWithInfo: Unexpected error occurs during executing get latest plugins

at com.kms.katalon.plugin.service.KStoreRestClient.getLatestPlugins(KStoreRestClient.java:80)

at com.kms.katalon.plugin.service.PluginService.fetchLatestPlugins(PluginService.java:196)

at com.kms.katalon.plugin.service.PluginService.reloadPlugins(PluginService.java:71)

… 2 more

This is a known limitation of the Studio:

This has been brought to the attention of the Katalon team, so hopefully it will be fixed soon. In the meantime, I suggest using a 5.0 version of the studio, where basic reporting was built-in and did not require access to the plugin store.

Hi Brandon,

Thank you for the quick reply on my previous post and I have started working with Katalon Studio 5.0.1 version. And here I have encountered with different issues.
while I am performing web testing, I am unable to replay the test steps and my click action is not working.
And this is without the proxy;

When I am at my work location and while using proxy I am not even able to open the browser while replay.

Additional information if needed: I am using the chrome browser extension Katalon recorder 3.9.

Error Details to the above:

Unable to click on object ‘Object Repository/c/Page_Sign in - Google Accounts/span_Create account’ (Root cause: com.kms.katalon.core.webui.exception.WebElementNotFoundException: Web element with id: ‘Object Repository/c/Page_Sign in - Google Accounts/span_Create account’ located by ‘By.xpath: //span[count(. | //[@class = ‘NlWrkb snByac’]) = count(//[@class = ‘NlWrkb snByac’])][count(. | //[text() = ‘Create account’]) = count(//[text() = ‘Create account’])][count(. | id(“ow254”)/span[@class=“I3EnF oJeWuf”]/span[@class=“NlWrkb snByac”]) = count(id(“ow254”)/span[@class=“I3EnF oJeWuf”]/span[@class=“NlWrkb snByac”])]’ not found)