Kalaton Studio GUI Linux - Error 'unable to save part'

So … long story short, after reading some hints here and there, I managed to finally run katalon 6.1.5 (yeeei!), almost decently,
on Linux, with GUI, by tweaking the ini file (added the --launcher.GTK_version option and changed the Xmx value).

OS used - redcore linux (gentoo derivate) with kernel 4.19.20, gcc-8.2.0, glibc-2.28-r1337, gtk±2.24.32-r1337, webkit-gtk-2.22.6

Portage 2.3.62 (python 3.5.5-final-0, default/linux/amd64/17.0/hardened, gcc-8.2.0, glibc-2.28-r1337, 4.19.20-redcore-lts-r1 x86_64)
System uname: Linux-4.19.20-redcore-lts-r1-x86_64-Intel-R-_Core-TM-_i7-4785T_CPU_@_2.20GHz-with-glibc2.4
KiB Mem:    16338056 total,   7749888 free
KiB Swap:          0 total,         0 free

sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.31.1 p5) 2.31.1
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.5.5::gentoo
dev-util/cmake:           3.14.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r1812::redcore
sys-apps/openrc:          0.34.11-r8::redcore
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.31.1-r1337::redcore
sys-devel/gcc:            8.2.0-r1337::redcore
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r1337::redcore
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.14-r1337::redcore (virtual/os-headers)
sys-libs/glibc:           2.28-r1337::redcore

Java version:

$ java -version
openjdk version "1.8.0_191"
OpenJDK Runtime Environment (IcedTea 3.10.0) (Gentoo icedtea-3.10.0)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

The ini file used content:


Now the funny part, attempting to create a WebRequest, once I hit ‘Save’ it spit’s he following error, see the screenshot:

Tweaks I tried:
Somehow in the end i managed to create a web-request (manually I think)… however, when hitting Play, nothing happens.
After that I tried to make a test case, same behaviour, attempting to save it raise the same error (unable to save part). Closing Katalon and re-opening, the script was there and sort of working.

But those are different stories, let’s try for the moment to focus on the main issue.

Attached the log starting with a clean session /project and attempting to create a Draft Request > saw some NPE in there:

katalon_log.zip (2.5 KB)

If any additional info about the system are needed, please let me know.

1 Like

Hi @Ibus,

Please install:



1 Like

@duyluong Please explain how to install those libs.

Please remember, this is a knowledgebase and not everyone knows how to install random libs. And not everyone has a Java background, either (me included!) :stuck_out_tongue:

@duyluong … mhm … you may have a point, the libs provided by the webkit-gtk package installed are:


I can try some symlinks first, in theory those libraries should be backward compatible.
If no success i have to find a way to get them in gentoo.

Will try and revert.

That’s hard, is specific to distribution in use. In ubuntu should be available as packages with the corresponding name and can be installed via apt-get, for my case will be tricky

That’s linux voodoo in fact, not Java :smiley:
it’s aboout needed .so libs … sort of .dll’s compared with windows

1 Like

So … I found some time to play a bit more with Katalon for Linux GUI.

Up to now I have like this:

  • In ubuntu 16.04 Xenial Xerus it worked, after installing libwebkitgtk-1.0-0 and libwebkitgtk-3.0-0 packages and with the pimped .ini file. Some glitches here and there but is usable.
  • Same in 18.04 Bionic Beaver

Now the fun part. Attempting to use it in ubuntu Disco Django … the are no such packages available, and looking into launchpad it is not clear if they intend to add them.
Looking into the webkit project on gnome, the reason behind it may be that, in their view, libwebkitgtk gen. 1 is deprecated so libwebkitgtk2 has to be used instead.

Gentoo appears to be already migrated to libwebkitgtk2. I haven’t looked into Arch and Fedora yet.
I tried in Gentoo to symlink the missing .so to the libwebkitgtk2 ones … no success.

I have also tried to manually grab from ubuntu the missing .so’s and put them in place … it failed.
Perhaps some missing deps … or something else.

So, before to attempt any other approaches, a quick question:

@duyluong there is any plan to migrate to the newest libwebkitgtk2?
that may open the usability for more distributions.
Or should I try some other voodoo to properly bring the needed libwebkit lib’s and dependencies into my system?

i closed this as it is inactive