Error ::setupKatalonTestGtk-Message: GtkDialog mapped without a transient parent. This is discouraged


#1

While ruunig Katalon Test Suite on Linux(via Jenkins), I am getting the below error.
:setupKatalonTestGtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

How can I resolve this issue


#2

I also get this error.

I’m using xubuntu, but should also work like ubuntu.

First of all I got other problems and have to chown and chgrp to my user.

But then I got the same error like Sumit_Ranjan.

I got following hint on stackoverflow, maybe it helps the developers of katalon studio?

Would be nice to run katalon studio on my xubuntu, because I would like to make a presentation in April for some other users.


#3

I solved this error by setting my user als owner and group for the configuration directory.

Now I get errors that ressources in the plugin folder could not be installed.

!SESSION 2019-01-14 15:31:12.338 -----------------------------------------------
eclipse.buildId=unknown
java.version=10.0.2
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64 -data config

!ENTRY org.eclipse.update.configurator 4 0 2019-01-14 15:31:15.210
!MESSAGE Could not install bundle plugins/org.codehaus.groovy.eclipse.compilerResolver_2.9.2.xx-201611170128-e46.jar A bundle is already installed with the name “org.codehaus.groovy.eclipse.compilerResolver” and version “2.9.2.xx-201611170128-e46”

Does I have to delete the plugin-folder?


#4

sorry, I found the thread to post issues in the beta release forum.

I guess my problem is, that I’m not using jdk8.

I’ll test it on a docker image or vm, because I don’t want to install an old java version on my productiv environment.


#5

Hello Sumit,

Could you resolve this issue?
If yes please share your solution.


#6

Thanks Andreas for giving the idea of changing owner and group. I changed both as jenkins which resolved the above error.