JSON Test Data does not work since updated to KR 5.5.4.1

Hi,
JSON test data seems not to work on KR 5.5.4.1 automatically updated today. It worked perfectly on previous version several minutes before updating. After the update, the JSON parsing seems not to work anymore. Maybe a regression due to CSV bugfix ?


Any idea on how to solve this issue ?
Thanks

1 Like

@david3

Can you show us your JSON file?

[{
“Question”: " What is the basic structure of a C++ program?, "
}, {
“Question”: " What are the Comments in C++?, "
}, {
“Question”: " Difference between Declaration and Definition of a variable., "
}]

1 Like

Hello,
I am receiving the issue with csv file format.
Attached file to ‘Test Data’ and used same type of test steps - as per previous version.
My Error message is: [error] TypeError: Cannot read property ‘data’ of undefined.
KatRecorderError1|99x500


Browser version: Chrome - 92.0.4515.159

@john.edwards

Can you provide me with your CSV file? We cannot reproduce this issue. Try loading the test data again from your machine to see if it works.

Hello ThanhTo,
I just realised that the system accepts the csv as a Zip.
(upload://hFn7Z7hGy5GzBECpg32f6P6Derg.zip) (155 Bytes)
Regards,

John.

@john.edwards

It doesn’t seem the upload was successful, can you try again?

Hi David,

We released a pre-release of 5.5.4.2 that fixed this issue. You can download and it and install in your Chrome locally. This version will be official once Chrome Web Store reviewed and approved it.

Same is happenning to me, but I noticed that the issue is only when executing the test in a Windows OS, in MacOS works fine.

In windows the error is the variables are not being expanded, so it is using the literal “${password}” instead of the value from the json file.

Code used is (with its proper “loadVars | testdata.json” ):

Json data file (somehow I cannot upload a json file):

@hector.lopez

Can you try the version 5.5.4.2 above and see if it resolves the issue?

After download the ZIP file, unpack it and load it into Chrome, I got a bunch of errors, like:


and few others. is this normal?

@hector.lopez

Yes that’s normal, as long as it’s functional.

Hey @ThanhTo, yes, the new version fixes the issue when loading vars from json. Thanks mate!

1 Like

Hi @ThanhTo
I have installed v5.5.4.2 and that’s perfect the issue is solved.
CSV was working in v5.5.4.1. Now CSV and JSON are working in v5.5.4.2.
Thanks a lot.

1 Like

4 posts were split to a new topic: Help use Test Data in KR

Hi all, KR 5.5.4.2 is public now, since users have confirmed that it resolves both CSV and JSON problems, I’m go ahead and mark it as resolved. Thank you for your understanding!