Is Katalon Studio unable to open the latest version of Chrome?

I am using version 121.0.6167.161 of Chrome and version 8.6.8 of Katalon Studio Enterprise and every test I run the browser won’t open including old tests that have never had any issues with opening the browser. I tried updating the webdriver as well and the issue persisted. I’ve seen issues like this in the past where Katalon hasn’t had a chance to update to account for a new version of Chrome releasing. Does anyone know if that’s the case here?

@adam.noodelman
Can you share the full console log to investigate?
From my side, I can run the tests from KS 8.6.8 and Chrome 121:

Thanks

I just upgraded the Edge Chromium driver to 121 this morning but I don’t believe it was 121.0.6167.161. Did you upgrade Chrome, Edge or Edge Chromium?

You can check the status of “Chrome for Testing” browser for automated testing at

https://googlechromelabs.github.io/chrome-for-testing/

What is “Chrome for Testing”? How is it similar to / different from Chrome? Read this:
Chrome for Testing: הורדות אמינות לאוטומציה של הדפדפן  |  Blog  |  Chrome for Developers

This page tells that the v121.0.6167.160 of “Chrome for Testing” is NOT ready. I have no idea what’s wrong in it. All we should do is to refrain from the version.

So, the cause of the problem possiblly resides in the latest version of Chrome, not in Katalon Studio. If you have got any problem, you should downgrade your Chrome installation and configure it so that it does not auto-upgrade.

It would be a good idea to use “Chrome for Testing” as I did before. Chrome for Testing v121.0.6167.85 would work OK and won’t auto-upgrade at all.

Hi @kazurayam @adam.noodelman
You can refer to this: https://katalon-inc.my.site.com/katalonhelpcenter/s/article/Issue-Unable-to-upgrade-Chromedriver121

No, I can not refer to this URL. The URL seems to be private, not open to the request from the public internet.