iOS device plugged into a Mac Mini are not visible in Katalon while it is when plugged into MacBook

Hi All,

Done everything on Mac Mini from:

Even set the following after homebrew installation:

  1. libimobile-device (brew install --HEAD libimobiledevice -g)

  2. ideviceinstaller (brew install ideviceinstaller -g)

And the following after carthage installation and before appium installation:

  1. ios-deploy(npm install -g

Also checked if my device is recognized using the following commands on Terminal:
cd /Applications/Katalon\ idevice_id -l

When I opened Katalon Studio (Mobile Object Spy), only list of Simulators are present in Device Name drop-down but my real device is Not. Then I plugged a real android device and it is visible as well.

Done the same steps on MacBook with the same device, OS and Katalon versions. As a result, my real device appears in the drop-down (even before configuring Xcode).

Device: iPhone 6s with iOS version 10.3.3
Mac OS version: High Sierra 10.13.6
Katalon Studio version: 5.6.1

Please help with the problem on Mac Mini.

Many thanks in advance.

I have had the same situation on our Macbook Pro here as well. Spent hours via Skype with a Forum moderator trying to determine the cause. I was able to run tests directly on the device via katalon without issue, etc. However, no matter what we tried we could not get the device to be listed in the dropdown of devices…only simulators were listed.

It came down to me being told that the MAC I was using may be too old of a model (its from 2013) and I should try a different MAC to see if I get the same or different results. The other issue with this MAC is that XCODE and other development tools were already installed and it has about 5 other user profiles on it…so its not clean. That could also have something to do with it.

However, I have tried all of the troubleshooting guides, installed appium doctor and all came back with clean results.

If you do find a solution, please let me know as I believe our issues may be one in the same.

Hi Kevin,

Thank you for you answer!
I will update if l find a solution.

Hope to receive an answer from Katalon Team or anyone who can help.

did you find a solution please ?

One of the first things you can do is see if the device is recognized by command line tools outside of Xcode:

idevice_id -l

If that does show your device, then it could be that you don’t have permissions to run some of the other command line tools that Katalon (and Appium behind the scenes) require. You can reinstall those tools with:

brew uninstall ideviceinstallerbrew uninstall libimobiledevice
brew install --HEAD libimobiledevice
brew link --overwrite libimobiledevice
brew install --HEAD  ideviceinstaller
brew link --overwrite ideviceinstaller
sudo chmod -R 777 /var/db/lockdown/

Hope this helps,