Plugged in Devices not appearing in Katalon Studio

I have followed all instructions within the following URL: https://dzone.com/articles/setting-up-mobile-automation-project-in-macos-with without error.

I can execute tests against the jacked in IOS Devices from XCODE without issue, both from with the XCODE and from command line.

When
I open Katalon, a whole listing of Simulators are present but the
actual IOS Devices connected via USB are not present. I have ensured
the devices are trusted, all Developer options are set correctly as
stated within the article listed above. I have reinstalled everything
(Homebrew, Carthage, Node/NPM and Appium) all with the same result. At
this point I am at a complete loss on how to proceed.

## OS (OS X High Sierra):

## Katalon Studio Version (5.6.0)

## Environment (for Mobile testing)

* Appium version ( 1.81)

* Mobile platform/version under test( iOS 11.3 and .4 )

* Real device or emulator/simulator (iphone8 (Real), IPAD 6 (Real))

* Xcode version (for iOS) ( 9.4.1 )

Can you try again with this guideline : https://docs.katalon.com/display/KD/Mobile+on+macOS#MobileonmacOS-iOS, especially this guide: https://docs.katalon.com/display/KD/Installing+WebDriverAgent+for+iOS+devices ? The guide above looks like it is outdated

Vinh: Thank you for responding. I have performed all steps within both guides: (Especially) https://docs.katalon.com/display/KD/Installing+WebDriverAgent+for+iOS+devices. As stated, I can execute against the device fine in XCODE both from the Terminal and within the application. However, the device is still not appearing within Katalon -> Project -> Test Case -> Run -> IOS.

http://docs.katalon.com/display/KD/Troubleshooting+automated+mobile+testing

iOS

  • Connect your device to Xcode.

  • Go to Settings -> Developer > turn ON UIAutomation.

  • Check if your device is recognized using the following commands on Terminal

    cd /Applications/Katalon\ Studio.app/Contents/Eclipse/configuration/resources/tools/imobiledevice idevice_id -l
    

    If your iOS version is iOS 11, make sure Katalon Studio’s version is 5.3+.

Can you help to execute the above command from your side?

Vinh: I ran the command you provided and it appear two instances of the devices UDID are returned within the terminal window.

As I have stated, I am able to run/test applications without issue within XCODE and within the terminal using xcodebuilder on multiple devices. All devices are recognized and appear within the devices -> Xcode section. I have re-installed Homebrew, Carthage, etc all with no result. I have uninstalled and re-installed Appium and ensured all appium dependencies (libimobiledevice and ios-deploy) are installed also.

Oh, there are two instances of devices UDID in this case. Can you post for me a screenshot of its?

There are two instances of devices UDID? Can you show a screenshot of its?

Of course, now that I go to get the screen shot only one instance appears in the terminal. However, the device is still not listed in Katalon. I have tried three different devices both above and below IOS version 11, same issue.

Facing the same issue here. The real devices connected are not listed. Followed the guidelines provided in https://docs.katalon.com/katalon-studio/docs/installing-webdriveragent-for-ios-devices.html and https://docs.katalon.com/katalon-studio/docs/mobile-on-macos.html .

Also ran the following commands,

cd /Applications/Katalon\ Studio.app/Contents/Eclipse/configuration/resources/tools/imobiledevice idevice_id -l

There are two instances of the device UDID which are displayed, but still the devices are not listed under local devices.

  • MacOS Version : 10.13.2
  • Mobile/Real device version : 11.4.1
  • Appium Version : 1.8.1
  • **Katalon Version : 5.8.6 **

Please help in resolving the issue.

It could be that you don’t have permissions to run some of the other command line tools that Katalon (and Appium behind the scenes) require. You can reinstall those tools with:

brew uninstall ideviceinstallerbrew uninstall libimobiledevice
brew install --HEAD libimobiledevice
brew link --overwrite libimobiledevice
brew install --HEAD  ideviceinstaller
brew link --overwrite ideviceinstaller
sudo chmod -R 777 /var/db/lockdown/

Hope this helps,

Chris

Hi Chris,

We tried the above solution provided by you. But, no luck. Devices are not listed in Katalon.
If this is case, then we cannot Katalon as a tool for Mobile Automation for iOS.

Hi Reshma,

Another thing you could try is to reset the trust settings between your device and the computer. Here are a couple of articles about that. You can see if it works to get the trust prompt to show again (and hopefully your device recognized):

http://osxdaily.com/2014/03/24/trust-this-computer-alert-ios/

https://www.idownloadblog.com/2015/09/01/how-to-untrust-iphone-ipad/

Hope this helps,

Chris

Thanks for the reply Chris.
I am getting a different error while trying to “brew install --HEAD libimobiledevice”. The error is as follows :

Anupama:WebDriverAgent anupama$ brew install --HEAD libimobiledevice

Updating Homebrew…

Error: Your Xcode (9.4.1) is too outdated.

Please update to Xcode 10.1 (or delete it).

Xcode can be updated from the App Store.

Here it says we would require xcode 10 to install, but there is a block if we move over to xcode 10 as katalon supports appium version 1.6, 1.7 and 1.8 only and these appium versions have an issue with parsing the double digit version number of xcode, please take a look on this issue https://github.com/appium/appium/issues/10810.

Is there any solution for this issue, or is katalon team planning to release a version which supports appium 1.9.1? Please help.

Hi Anupama,

You’re right, Katalon Studio doesn’t support Xcode 10 yet, however, you CAN have multiple versions of Xcode installed on the same machine. You could download Xcode10.1 from the Apple Developer Center: https://developer.apple.com/download/

When you install it, choose that you want to keep both versions and name the new Xcode something like Xcode10.1.

You can then switch between the version of Xcode that command line tools use with:

For Xcode 9 (or whatever your default installed version is):

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

and for Xcode 10:

sudo xcode-select -s /Applications/Xcode10.1.app/Contents/Developer

So, in order to use the brew commands, you can switch to the Xcode10 tools, and before you run Katalon Studio, switch back to the Xcode9 version.

Hope this helps,

Chris