Installing WebDriverAgent for iOS devices


This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/installing-webdriveragent-for-ios-devices.html

Hi
I am not getting Listening to USB. I completely followed the instructions…

I’m receiving build failed everytime even though I followed the steps

@Rob2

Please share the build error.

Build error ->
Signing for “IntegrationApp” requires a development team. Select a development team in the Signing & Capabilities editor.

I have followed all the steps and added a development team but keep getting the error

I’m trying to setup all the installation Appium on macOs Catalina to test iOs application.
I followed all the steps, but at the end it is impossible to build the WebDriverAgentRunner and the IntegrationApp.

My setup is :

  • Appium 1.17.1 (classic and Desktop)
  • Carthage 0.34.0
  • Appium doctor v.1.15.3
  • XCode 11.5

The build of WebDriverAgentLib works well.

But the build of WebDriverAgentRunner and the IntegrationApp failed with the error “/usr/local/lib/node_modules/appium/node_modules/appium-webdriveragent/WebDriverAgentTests/IntegrationApp/Resources/Base.lproj/Main.storyboard:1:1: Compilation Failed.”

Log :
log-appium-webdriver.log (7.0 KB)

Do you have any idea ?

After quite the feud with darn near everything, I finally made it all the way to the building step, but now that fails for the sake of the errors above. ^ Anyone know what that is or what I need to do about it to get the build to work?

@joshw

Please run these commands and make sure the commandline returns the success result:

cd /usr/local/lib/node_modules/appium/node_modules/appium-webdriveragent
mkdir -p Resources/WebDriverAgent.bundle
sh ./Scripts/bootstrap.sh -d

appium-webdriveragent_—-bash—_80×24_and_GitHub_Desktop

Looks good, as far as I can tell, @duyluong.

@joshw

These above steps are fine.
Now you can build the WebDriverAgent again:

  • Build IntegrationApp
  • Build WebDriverAgentLib
  • Build WebDriverAgentRunner

@duyluong, building the IntegrationApp works, with some warnings, but I get the same errors as before when trying to build the WebDriverAgentLib and WebDriverAgentRunner.

Also, another question, because I’m very much a newb at this. Are these webDriverAgent builds necessary for running Katalon with my iOS simulators, or is it only important for running Katalon tests on a connected, physical device? I was a little unclear on that when going through the setup steps.

Thanks so much for the help!

Every step mentioned is done without any errors, build WebDriverAgentLib,WebDriverAgentRunner. The problem starts when trying to build integration app. it shows compilation failed Main.storyboard. Any other option or way to resolve this.

The easiest way to get up-and-running with Appium’s XCUITest support on iOS real devices is to use the automatic configuration strategy. There are two ways to do this:

Use the xcodeOrgId and xcodeSigningId desired capabilities:
{
“xcodeOrgId”: “”,
“xcodeSigningId”: “iPhone Developer”
}
Create a .xcconfig file somewhere on your file system and add the following to it:
DEVELOPMENT_TEAM =
CODE_SIGN_IDENTITY = iPhone Developer
In either case, the Team ID is a unique 10-character string generated by Apple that is assigned to your team. You can find your Team ID using your developer account. Sign in to developer.apple.com/account, and click Membership in the sidebar. Your Team ID appears in the Membership Information section under the team name. You can also find your team ID listed under the “Organizational Unit” field in your iPhone Developer certificate in your keychain.

Note that these are mutually exclusive strategies; use either the xcodeConfigFile capability or the combination of xcodeOrgId and xcodeSigningId.

Once this configuration is done, it should just be a matter of starting your test specifying a real device in your udid desired capability.

If this has not worked it will usually manifest itself in the Appium server logs as some error followed by info XCUITest xcodebuild exited with code ‘65’ and signal ‘null’. This usually means that the necessary code signing is not set up correctly. Go on to the Basic (manual) configuration to fix.

If the WebDriverAgentRunner is successfully installed on the device, but in the Appium logs there is an error message something like:

2017-01-24 09:02:18.358 xcodebuild[30385:339674] Error Domain=com.apple.platform.iphoneos Code=-12 “Unable to launch com.apple.test.WebDriverAgentRunner-Runner” UserInfo={NSLocalizedDescription=Unable to launch com.apple.test.WebDriverAgentRunner-Runner, NSUnderlyingError=0x7fa839cadc60 {Error Domain=DTXMessage Code=1 “(null)” UserInfo={DTXExceptionKey=The operation couldn’t be completed. Unable to launch com.apple.test.WebDriverAgentRunner-Runner because it has an invalid code signature, inadequate entitlements or its profile has not been explicitly trusted by the user. : Failed to launch process with bundle identifier ‘com.apple.test.WebDriverAgentRunner-Runner’}}}
2017-01-24 09:02:18.358 xcodebuild[30385:339674] Error Domain=IDETestOperationsObserverErrorDomain Code=5 “Early unexpected exit, operation never finished bootstrapping - no restart will be attempted” UserInfo={NSLocalizedDescription=Early unexpected exit, operation never finished bootstrapping - no restart will be attempted}

Testing failed:
Test target WebDriverAgentRunner encountered an error (Early unexpected exit, operation never finished bootstrapping - no restart will be attempted)

Hello, I have followed the steps exactly and am getting the same error that was mentioned above.

Signing for “IntegrationApp” requires a development team. Select a development team in the Signing & Capabilities editor.

Any help would be greatly appreciated. Thanks!

@nwolfe

Can you share some screenshots of the error?

The error is exactly as I mentioned above:
Signing for “IntegrationApp” requires a development team. Select a development team in the Signing & Capabilities editor.

I believe this was caused by the bundle identifier not being unique, I had changed this to a unique value and am no longer getting the error message. Thanks!

I am currently getting same error even though I have developers account