Installing WebDriverAgent for iOS devices

  Building for iOS Simulator, but the embedded framework 'CocoaAsyncSocket.framework' was >built for iOS + iOS Simulator.
  Building for iOS Simulator, but the embedded framework 'YYCache.framework' was built for >iOS + iOS Simulator.
  Building for iOS Simulator, but the linked and embedded framework 'YYCache.framework' was >built for iOS + iOS Simulator.
  Building for iOS Simulator, but the linked and embedded framework >'CocoaAsyncSocket.framework' was built for iOS + iOS Simulator.

Recently, I got this error when I run a test on iOS Simulator.
Does anyone know how to fix this? I try to go to set BuildSettings ->“Validate Workspace” to Yes
But it doesn’t work.

I am getting the following error when I attempt to build to a device.

Unable to install “IntegrationApp”
Domain: com.apple.dt.MobileDeviceErrorDomain
Code: -402620415

An unknown error has occurred.
Domain: com.apple.dt.MobileDeviceErrorDomain
Code: -402620415
User Info: {
DVTRadarComponentKey = 280331;
MobileDeviceErrorCode = “(0xE8008001)”;
“com.apple.dtdevicekit.stacktrace” = (
0 DTDeviceKitBase 0x000000011f39099f DTDKCreateNSErrorFromAMDErrorCode + 220
1 DTDeviceKitBase 0x000000011f3cf164 __90-[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:]_block_invoke + 155
2 DVTFoundation 0x0000000102990993 DVTInvokeWithStrongOwnership + 71
3 DTDeviceKitBase 0x000000011f3ceea5 -[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:] + 1440
4 IDEiOSSupportCore 0x000000011f23f7bc __118-[DVTiOSDevice(DVTiPhoneApplicationInstallation) processAppInstallSet:appUninstallSet:installOptions:completionBlock:]_block_invoke.292 + 3513
5 DVTFoundation 0x0000000102abf2ae DVT_CALLING_CLIENT_BLOCK + 7
6 DVTFoundation 0x0000000102ac0ed0 __DVTDispatchAsync_block_invoke + 1191
7 libdispatch.dylib 0x00007fff725256c4 _dispatch_call_block_and_release + 12
8 libdispatch.dylib 0x00007fff72526658 _dispatch_client_callout + 8
9 libdispatch.dylib 0x00007fff7252bc44 _dispatch_lane_serial_drain + 597
10 libdispatch.dylib 0x00007fff7252c5d6 _dispatch_lane_invoke + 363
11 libdispatch.dylib 0x00007fff72535c09 _dispatch_workloop_worker_thread + 596
12 libsystem_pthread.dylib 0x00007fff72780a3d _pthread_wqthread + 290
13 libsystem_pthread.dylib 0x00007fff7277fb77 start_wqthread + 15

Please advise.

Hey, while building I get the following error:

Any idea what to do?

Thanks and Regards

When following the steps above
cd /usr/local/lib/node_modules/appium/node_modules/appium-webdriveragent
mkdir -p Resources/WebDriverAgent.bundle
sh ./Scripts/bootstrap.sh -d

When I get to sh ./Scripts/bootstrap.sh -d

I get the error message saying sh: ./Scripts/bootstrap.sh: No such file or directory

or if I run sudo ./Scripts/bootstrap.sh -d
i get sudo: ./Scripts/bootstrap.sh: command not found

any suggestions?

1 Like