iOS mobile testing build webDriverAgentRunner failed

I want to do the testing on my real mobile device(not simulator),but I failed to build the webDriverAgentRunner on xcode and I don’t know how to fix is the error:


Screen Shot 2018-10-23 at 10.36.52.png

Hi Ken,

Can you share what the screen looks like for the WebDriverAgent->General screen?

It should look something like this:

Screen Shot 2018-11-06 at 11.35.15 PM.png

Hi Chris,
First I followed the iOS Configuration (Katalon Studio for Mobile Testing on macOS)
I got stuck in Product > Build

I’m also having the same issue, once I tried to Product > Build, I got the same issue “Build Failed”
I followed your steps in WebDriverAgent->General

Tried to run “Build” but I still got the same issues:
Semantic Issues:

Also Lexical or Preprocessor Issue Group:
/Users/mac/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgentLib/Routing/FBWebServer.m:12:9: ‘RoutingHTTPServer/RoutingConnection.h’ file not found

Screen Shot 2018-11-14 at 7.07.15 PM.png

Screen Shot 2018-11-14 at 7.08.25 PM.png

Got some screenshots for reference:

Screen Shot 2018-11-14 at 7.56.50 PM.png

Screen Shot 2018-11-14 at 7.54.12 PM.png

Hi Aaron,

Can you share what version of Xcode and Appium you’re using?

Those warnings tell me there may be either an incompatibility with the version of Xcode or one of the support libraries wasn’t installed correctly.

To check this out, you can go to the directory where Appium’s WebDriverAgent project exists. If you open that directory in Terminal and run “ls -al”, you should see something that looks like this:

drwxr-xr-x   3 chris  staff    96 Sep  4 12:54 .circleci
-rw-r--r--   1 chris  staff   761 May 22 18:19 .npmignore
-rw-r--r--   1 chris  staff   821 May 22 18:19 .travis.yml
-rw-r--r--   1 chris  staff  1324 May  1  2018
-rw-r--r--   1 chris  staff   116 May 22 18:19 Cartfile
-rw-r--r--   1 chris  staff    80 May 22 18:19 Cartfile.resolved
drwxr-xr-x   5 chris  staff   160 Sep 13 11:25 Carthage
drwxr-xr-x   3 chris  staff    96 Sep  4 12:54 Configurations
drwxr-xr-x   4 chris  staff   128 Sep 13 09:37 DerivedData
drwxr-xr-x  12 chris  staff   384 Sep 13 11:25 Inspector
-rw-r--r--   1 chris  staff  1535 May  1  2018 LICENSE
-rw-r--r--   1 chris  staff  1985 May  1  2018 PATENTS
drwxr-xr-x   3 chris  staff    96 Sep  4 12:54 PrivateHeaders
-rw-r--r--   1 chris  staff  2647 May  1  2018
drwxr-xr-x   3 chris  staff    96 Sep 13 11:25 Resources
drwxr-xr-x   4 chris  staff   128 Sep  4 12:54 Scripts
drwxr-xr-x@  7 chris  staff   224 Nov  5 13:31 WebDriverAgent.xcodeproj
drwxr-xr-x  16 chris  staff   512 Sep  4 12:54 WebDriverAgentLib
drwxr-xr-x   4 chris  staff   128 Sep  4 12:54 WebDriverAgentRunner
drwxr-xr-x   5 chris  staff   160 Sep  4 12:54 WebDriverAgentTests

The thing to note is the Carthage entry - if the line doesn’t start with a “d”, it means that it’s not a directory and probably doesn’t have the right dependencies.

You can try doing the following to correct it:

rm -rf Carthage
mkdir Carthage
sh ./Scripts/ -d

Once that is done, you can try to reopen and rebuild the project.

Hope this helps,


Hi Chris, followed the steps and here’s the screenshot, I noticed I don’t have the .npmignore?

Screen Shot 2018-11-19 at 10.02.47 AM.png

I wouldn’t worry about the .npmignore file.

Do you still get the same error when building the Xcode project?

Hi Chris, after setting the target to the IntegrationApp it did successfully Build. Thank you!

follow up question,
our app is in app store connect, is there any chance I’ll be able to get it locally? As a .ipa file?

Hi Aaron,

Glad to hear it’s working!

As for downloading the IPA, you might be able to do it using these instructions:

However, I think you might still need the provisioning profile and certificate if you want to put it on a device. Additionally, IPA files don’t usually work on simulators, since they are built for the real device architecture. You’d probably be better off getting the Xcode project (if available) and building it locally for simulators. Then you can pick up the generated .app file (from your project’s DerivedData directory) and install it on other simulators/machines.

Hope this helps,


Thank you @Chris Trevarthen I have an iPad pro and will try to use Katalon for it. Is there any detailed tutorial for Katalon Studio iOS device testing?

Hi Aaron,

There are a couple of places you can see documentation for iOS device setup with Katalon Studio:

Similar documentation from Appium about real device setup:

Hope this helps,


in xcode apps ,how to signin or i set the user as developer?