ID not found on re-run, but was recorded and is highlighted if requested


#1

I have a test that is trying to select a label in a drop-down menu. This worked fine in Selenium IDE, but wont work in Katalon Recorder.

The selection’s target is id=select74

If I re-record the test in Katalon, then Katalon recorder also records the target as id=select74

When I run the test, I get an error saying that the element is not found. But, I can see it, and if I do an inspect, I can see it in the HTML.

If I use the little magnifying glass in Katalon to highlight the element, then it’s highlighted, so Katalon can obviously find it - but the log prints out “Unknown error”.

Anyone got any ideas or pointers to help me debug this?


#2

OK, I have found the issue (which has lead to more) but this is what’s going on.

The element I want to select is in an iFrame. The old Selenium IDE didn’t care about that on the record or re-run. Katalon recorder does.

When making the recording, Katalon doesn’t record the fact that you have switched frames, so when you run the test back later, it doesnt see the element in the frame you are in. If you add a manual command to switch the the iFrame the element is in, then it works. Well, kind of works. The selectFrame command doesnt work properly, but if it did, then all would be well. I have added to the bug forum on that.


#3

What is the command syntax to chage the frame ? what doesnt work exactly ? having the same problem now


#4

Sorry, in the end, I recoded the app to remove iFrames (it was easier!!). So, I can’t help you I’m afraid.