How to connect to Database with Active Directory Authentication Type


#1

Hello,

I am unable to connect to the Database using my Active Directory credentials. The database I am trying to connect to does not have any direct SQL logins and we can only access it using Active Directory.

Every time I try to connect, it says “Cannot open server requested by logon”.

Please help.


#2

image

I have downloaded and added the “sqljdbc_auth.dll” file into the Katalon_Studio_Windows_64-5.6.0\jre\bin folder. Tried the 32 bit and 64 bit file.

I have tried adding “Authentication=ActiveDirectoryIntegrated;integratedSecurity=True” to the connection string.

I am getting the error “Connection Failed! This driver is not configured for integrated authentication”

Not sure if I should be entering a User and Password.

I am using the connection URL “jdbc:sqlserver://fake-01.database.windows.net;databaseName=RA34363T;IntegratedSecurity=True;”

Can someone please help? I have attached pictures of the error I am getting in Katalon and how I connect in SSMS successfully.


#3

Shout out: @ThanhTo @duyluong


#4

lets summon my grandson
@Mihai_Augustin_Sarat nepoate, do you still have the script we used ?


#5

@anpatel
I don’t have access anymore to the exact code, but the script was somewhat like this.
In cmd you type:

runas /netonly /user:domain\username “C:\path_to\ssms.exe”

And in Katalon we had a custom keyword that would handle the connection and the queries. We did not use the Katalon’s test data feature.
This example is for MySQL and not T-SQL. Please update the required fields to form a T-SQL connection.
https://docs.katalon.com/katalon-studio/docs/connect_db_gui_testing.html


#6

thanks grandson. i think starting from this we can extrapolate a working solution by using various tweaks (execute powershell or dig into powershell objects)


#7

I was hoping there would be a more simple way of connecting. I would like to use Katalon’s test data feature and was hoping to get some guidance on what is wrong with the Connection URL and if I should or should not be checking the “Secure user and password” checkbox.