Execution Settings


#1

This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/execution-settings.html

#2

The execution settings for Android doesn’t work, whenever I try to execute a test using a custom settings, Katalon says no device found, when I execute it from the default settings (custom setting have the same settings) it works. There is some kind of bug here.


#3

This documentation could be in need of an update, since the menu structure shown is not the same as in version 6.1.
In 6.1, there is no subsection under “Execution”, but there is a new “Desired Capabilities” section which contains “Custom”, “Web UI” and “Mobile”.
I would love to be able to use some sort of global variable when defining the Desired Capabilities, but this does not seem to be possible at the moment?


#4

I have problem with the Test Suite Collection and especially with the ( Run with ) row
There is no option like ( chrome , IE , Edge , Firefox )
there is only : Web Service.
I tried from the
( Setting => Execution => Desired Capabilities => Custom )
to find solution , but i cant

I tried to find the solution also in Katalon Docs but this is what i found https://docs.katalon.com/katalon-studio/docs/execution-settings.html#default-execution-settings

can you please help me ?


#5

Hi Moutaz,
It seems to me that you might have created Web Service project, but really need a standard Web project.
The lack of “Run with” options could (I have not verified this) be due to your Katalon Project being created as a Web Service project. See https://docs.katalon.com/katalon-studio/docs/apiweb-service-project-since-v58.html#toolbar
You could change the project type manually by changing your main project file (it has the .prj ending) so it contains
<type>WEB</type>
and not <type>WEBSERVICE</type>
Then restart Katalon, and you will see a change in the icons and options available to you.


#6

What is the default timeout for API request (e.g. WS.sendRequestAndVerify) ? And can it be changed in any settings (e.g. Default wait for element timeout) ?


#7

I have the same problem.
Test case runs well, whereas, it doesn’t open the browser with test suite collecction.
the error message is No driver is set for execution.

Need Help pls


#8

Hello All,
I have a similar issue.
I am trying to run my test suite in cross browser testing tool. I am working on Katalon studio 6.1.5
I can see two options to do this but none of the options are working for me.

  1. To run the test suite by clicking Run–> Remote and then enter the remote web driver server URL (for cross browser testing tool) in the dialog box which pops up when you click Remote

The URL I am using here is :
http://“My-User-Name-found-from-cross-browser-tool”:“MyAuthKey-FoundInTheCrossbrowserTool”@hub.crossbrowsertesting.com:80/wd/hub

1.1 Question is how does it know about the other specification like Driver Name, os, os version etc.
1.2 Test suite fails with below error
c.k.k.core.webui.driver.DriverFactory - Connecting to remote web server ‘http://“My-User-Name-found-from-cross-browser-tool”:“MyAuthKey-FoundInTheCrossbrowserTool”@hub.crossbrowsertesting.com:80/wd/hub’ with type ‘Selenium’
INFO c.k.k.core.webui.driver.DriverFactory - Action delay is set to 3 seconds
ERROR c.k.k.core.keyword.internal.KeywordMain - :x: Unable to open browser (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to open browser
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)
.
.
.
Caused by: org.openqa.selenium.WebDriverException: Unable to parse remote response: Capabilities must specify either a browserName or browser_api_name so we know what browser to launch.
Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘XXXXXXXXXXXXX’
System info: host: ‘XXXXXXXXX’, ip: ‘XXXXXXXX’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_181’
Driver info: driver.version: CRemoteWebDriver
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:111)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:73)

  1. To create custom capabilities Project–>settings–>Desired capabilities–> Custom–> Add
    (See attcahed images to view the settings)

In this option I dont see anywhere the option of entering the cross browser testing tool URL ( the way I had to give in option 1 http://“My-User-Name-found-from-cross-browser-tool”:“MyAuthKey-FoundInTheCrossbrowserTool”@hub.crossbrowsertesting.com:80/wd/hub

when I run the test suite its actually not running in cross browser testing tool … Its getting executed as normal test suite execution ( I know, the URL for cross browser testing tool was not mentioned anywhere … but where should I do it?/)

P.S. Cross Browser Testing Tool is similar to Browserstack tool

Thanks in advance.


#9

I am using Saucelabs and same issue faced.Any progress here anyone?


#10

thank you so much now everything is okay :grinning:


#11

What was the solution?