Emails Settings


#1

This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/emails-settings.html

#2

Hello Support,

It would be great to be able to include the profile of the executed suite in the email that is being received. A new variable like ${executionProfileName}.

Thank you,
Cornel Neacsu


#3

It would also be helpful to add new variable for test suite collection names (eg. ${collectionSuiteName}).

Also valuable to have the collection suite name sent to Katalon Analytics in addition to the suite names already there.

Thank you,
Mike Willett.


#4

Hello Katalon Team

I would be really helpful to provide details of how to fetch Hostname , Protocol , Port etc if user like to send email to his/her organization email address.


#5

@utkarsh.chaudhary, for corporate email, you can contact your local IT team to get SMTP Host ,Port number and protocol.
Port number is usually either 25 or 587 but better to confirm same from your local IT Team.


#6

Thanks @Sachin for reply .
I also tried with my gmail account but getting below error when tried to test email
“Unable to send email to the following server :smtp.gmail.com:25 . Please check configuration on your email server”.
I also check one thread that going on i.e .Mail setup not working properly
but unfortunately we didn’t configure email settings , please let us know what are the detail steps to setup email .


#7

Have you allowed less secure app to be logged in Gmail? That might be blocking your login.
Debug Point:

  1. Are you getting any mail while you try to send Test email? If you are getting any mail in your default account saying ‘last login blocked’ then possibly you do not have enabled less secure app login

  2. if you are not able to see any mail in your default account, there is something wrong with your creds or port or security protocol might be blocking this.


#8

I also had this problem. As Rudra have mentioned allow less secure app to access Gmail

  1. Go to https://myaccount.google.com/security
  2. Enable “Less secure app access”

Host : smtp.gmail.com
Port : 465
Protocol : SSL

I can’t seem to get TLS protocol working for Gmail, though

Btw I recommend creating a Gmail acc just for SMTP cause enabling less secure app will definitely make that Gmail acc more vulnerable


#9

Hello Team

I am to send email using my organization email , majority of the corporate email use outlook as their host , below are the details of domain and Port for outlook email
1.Hostname : outlook.office365.com
2.Port : 993
3.Username : User you organization username(do not enter you org email here , enter your org username which you use to unlock you PC) .
4.Password : User organization password
5.Protocol : TLS

I am still not able to solve the gmail issue .
@rudra : thanks rudra for your input , to answer you question
Have you allowed less secure app to be logged in Gmail? yes I have done that but still no luck
I will keep you guys posted once I found the solution


#10

Hi @utkarsh.chaudhary

I have just tried with my organization email which uses corporate email, office365.com as host. and successfully sent email. I have used below setting.

Host: smtp.office365.com
Port: 587
username: organization email
password: organization password
Protocol: TLS


#11

I echo @Cornel_Neacsu request of showing the profile name … this huge benefit as you can tell on which environment the test ran


#12

Hy Guys. Maybe something that would be great for people that works with multiple proyects, we migh need to be able to create multiple templates or Add “ProjectName” into the current list that Katalon already has.

Greetings