[error] Cannot read properties of undefined (reading 'getCommandHandler')

Hi, since yesterday I suddenly got below error on ‘storeHtmlSource’ and ‘storeText’ command in a Test Case which was working fine before.
Then I see that in happens to the Sample projects, offered by KR as well.
I see two old post with the same issue here but there isn’t any proper answer or solution for them
I’ve also tried it two different machines and get the same result.
Does anyone else face the same issue?
[error] Cannot read properties of undefined (reading ‘getCommandHandler’)

The issue was a js file in my scripts. Although I was not using that, it was causing error!


Let me investigate nd bck to you

Today I started to getting that error on steps that include ‘waitForElementPresent’ on a working Test Case. I’m using Katalon Recoder v5.9.0 in Win/Chrome. I uninstalled the extension and re-installed but no luck. I also tried using the Edge (v5.8.3) browser but same error.

Other steps like click and type work fine. Any idea what’s up?

:white_check_mark: Issue Solved!

Turns out I had inadvertently put a Test Data CSV file into the Extension Scripts folder.

I tried deleting the errant CSV file but that was not sufficient.

I tried deleting the file then making a backup and restoring but, the errant CSV file would again be in the Extension Scripts folder.

When I manually removed the Extensions section out of the JSON restore file, then Restored, everything went back to normal. :smiley: