Encountering "loading of unpacked extensions is disabled by the administrator"

When I click on ‘Start’ in Katalon Object Spy I get an error which says ‘loading of unpacked extensions is disabled by the administrator’ and the ChromeDriver fails to launch.

I am using company owned system. I don’t have full rights. Can somebody suggets, what I need to change for this to work?

Screen Shot 2018-03-20 at 5.12.42 PM.png

1 Like

Please try changing location of your chrome setup to some other drive in which you have read+write access.

I also work in a locked down environment and receiving the same error when selecting “Record Web” in Katalon Studio 5.3.1. Katalon Automation Recorder v3.4.11 is installed for Chrome 65.

The documentation implies to me that Katalon Automation Recorder must be installed separately.

Is there a way to avoid using this ‘unpacked extension’? If there is not, in my current security environment, I will never be able to record, or apparently, test against Chrome.

1 Like

What you said is correct . This update was informative. Also trying to change chrome setup won’t work if it comes with OS provided by company. We tried the same with no success.

when you work in locked down environment there are lots of restrictions. I’m new to Katalon and since this was posted almost 10 months back hope there is a way in Katalon 5.10 version.

Is there any news on this problem? I am still getting this on version 6.1.5 of Katalon.

I’m getting this issue for last couple of weeks, tried with different versions of Katalon, but no hope.

Is anyone got an update for this issue?

Our Company shares a similar fate.

We wrote an bug-ticket on Github:

Current Result: Katalon Studio v7.4.0 can’t execute chrome extensions in Google Chrome v83, when there is an active whitelist. You need to wait for an newer Version which supports it.

Cause: chrome extensions are loaded local from a folder (unpacked).
In comparison the Firefox extension is working (packed and signed).

I would recommend to leave this thread as it is and write an comment on the bug-ticket above too.
That should increase the significance of this error better an should lead to an accelerated resolution.

We are facing the similar issue with Katalon Studio 8.0.0 and Chrome V89 in restricted environment. Is there any workaround now?

Ask your Manager, or Supervisor, for an external drive and have your Security Analyst allow you to use a USB port to attach the drive? (I assume your USB ports are secured as well.) This is not the best method as you could lose everything with a simple drive error. Or, even better, ask your Manager, or Supervisor, for a location on the network to install and save your project files in which you can be given read and write permission and which is also backed up (nightly or weekly). If your Manager, or Supervisor, cannot give you the tools to do your job, then…

Just a note that if your Manager allows you to have a network drive location, you can occasionally get network glitches that may look like test failures (with messages about objects being null) but then will continue on again like nothing happened.

If you are given the external drive, you may be prevented from starting KS (because of the USB connection) if the Security people change their rules (or from updates). You will have to remind them about your external drive and have them fix their rule for you.

Edit: I don’t have the option but perhaps even a “cloud” install. ???

Hi everyone,

The issue of loading unpacked extensions on Spy, Record, Smart Wait features is currently resolved by Katalon Compact Utility.
Please find its information here: https://docs.katalon.com/katalon-studio/docs/katalon-compact-utility.html#configuring-and-using-katalon-compact-utility-with-chrome-profile.

Thank you all for your concerns,
Nam Nguyen.