Email settings not working

**OS **OSX High Sierra 10.13.6

Katalon Studio Version 5.6.0

## Katalon Studio logs: Attached

**#****#**Environment (for Web testing) Chrome68.0.3440.84

I’m having real difficulties setting up emailing to send a test report on completion.

I’ve tried various settings and settled on sending it via my personal email account with the following settings (having read various threads about this issue):

When I click Send test email, I get the following error:

I’ve looked in the logs and noticed the following “cause”:

com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.0 Must issue a STARTTLS command first

I’ve pinged and get a response, so there’s no issue there.

Anyone able to help please? It’d be massively useful if I can email out the test results.



Screen Shot 2018-08-09 at 12.13.59.png

Screen Shot 2018-08-09 at 12.16.36.png

ping is usually opened in company firewalls.
to get real info try to connect to port 465 using putty or another terminal software

Looks to be ok…

Screen Shot 2018-08-09 at 12.36.49.png

one more thing, please try to change protocol so SSL and check logs

Changed to SSL and still no luck.

I was pasting the wrong “cause” earlier. This is the latest entry in the logs…

!ENTRY org.eclipse.e4.ui.workbench 4 0 2018-08-09 13:15:33.835



org.apache.commons.mail.EmailException: Sending the email to the following server failed :

at org.apache.commons.mail.Email.sendMimeMessage(

at org.apache.commons.mail.Email.send(

at com.kms.katalon.execution.util.MailUtil.sendTestMail(

at com.kms.katalon.composer.execution.settings.MailSettingsPage$

at org.eclipse.jface.operation.ModalContext$

Caused by: javax.mail.AuthenticationFailedException

at javax.mail.Service.connect(

at javax.mail.Service.connect(

at javax.mail.Service.connect(

at javax.mail.Transport.send0(

at javax.mail.Transport.send(

at org.apache.commons.mail.Email.sendMimeMessage(

… 4 more

: javax.mail.AuthenticationFailedException

seems you connected, but username/password failed…

That’s strange as I’ve checked and double-checked the username and password. I’ve tried logging in with the exact same credentials to Google Mail and it’s fine.

And I’ve made sure I allowed insecure apps too.

This is SO frustrating!

i assume no 2 step auth is defined in google account used for test

Nope, checked that and it’s off.

Turns out I had the insecure apps enabled for the wrong account but I’ve now turned that on for the correct account. Still the same issue and the same cause in the logs

Thank you for all of your suggestions, really appreciate the help

Right, not sure what’s going on with Gmail but we have now got this working with my work email. Turns out there were some settings that needed turning on in the G Suite settings!

So, I now receive the test email, which is great. Unfortunately the information is incorrect in it and there’s no attachment, despite setting “Include report as email attachment” to HTML file!

This can be closed now, all seems to be working!

Thank you Andrej for all of your help and suggestions, really appreciate it

no problem, you are welcome

@Andrej_Podhajsky, @arulrajj, @Simon_Bunyard, @Chris_Trevarthen, @Dinesh_Srinivasan, @ellen.kurokawa, @IT.KatalonUser.Banco, @Katalon_Store, @Russ_Thomas,

My email is not working and throwing an error while running via Jenkins and on testing email, it comes to inbox but not when I trigger the suite.

System is unable to email report. Reason: net.lingala.zip4j.exception.ZipException: no files to add
at net.lingala.zip4j.core.ZipFile.addFolder(
at net.lingala.zip4j.core.ZipFile.addFolder(
at net.lingala.zip4j.core.ZipFile.addFolder(
at com.kms.katalon.execution.util.MailUtil.attach(
at com.kms.katalon.execution.util.MailUtil.sendSummaryMail(
at com.kms.katalon.execution.launcher.ReportableLauncher.sendReportEmail(
at com.kms.katalon.execution.launcher.ReportableLauncher.sendReport(
at com.kms.katalon.execution.launcher.ReportableLauncher.preExecutionComplete(
at com.kms.katalon.execution.launcher.ProcessLauncher.onWatchdogComplete(
at com.kms.katalon.execution.launcher.LaunchWatchdog.notifyProcessTerminated(

Try this: If you have a GMail account, use the settings in my post for the Server and Port, and your GMail address and password. Also, you need to click this link
( ), and log in with your GMail credentials in order to set “Apps with account access” - “Allow less secure apps:” to “ON”…

go to Katalon store > Login > My Account > Security > Copy (or create) your API key
Add the api to your console command -apiKey=“YOUR_KEY_GOES_HERE”

Try this setting.For me worked

1 Like

It does look like if you want to use a gmail account as your mailserver you do need to set the Protocol to SSL instead of None