Echo ${SomeStoreAttributeName} dosn't work


#1

[info] Executing: | store | Alex | author |

[info] Store ‘Alex’ into ‘author’

[info] Executing: | store | Alex | Name with spaces also works. See tab Variables. |

[info] Store ‘Alex’ into ‘Name with spaces also works. See tab Variables.’

[info] Executing: | storeEval | new Date().toString() | time |

[info] Store ‘Tue Nov 20 2018 13:52:55’ into ‘time’

[info] Executing: | storeTitle | page | |

[info] Store ‘Test page’ into ‘page’

[info] Executing: | echo | Added by ${author}. Time: ${time}. Page: ${page}. | |

[info] echo: Added by ${author}. Time: ${time}. Page: ${page}.


#2

I had the same issue few times. For me it was because i run by dobule click on the echo command. In that case it look like Katalon can’t recognize variables, but if i run the whole test case it’s work fine.

Maybe try whitout “.” after “}” or try wtih one variable at the time so you have 3 separate echo command.
And be sure you have all 3 variables in the Variables tab.