Again, webdriber incompatability issue with chrome browser arises.......!

I usually need to run scripts through GitLab pipeline. Some day ago, I reported a problem about incompatible webdriver error thrown when tried to run tests using Katalon docker image. My previous post is at

I then managed to run scripts using docker image 9.0.0.beta as mentioned in the post.

Today, I tried to run the scripts and again getting similar error, the webdriver has been updated but not the chrome browser as mentioned below

Starting ChromeDriver 118.0.5993.70 (e52f33f30b91b4ddfad649acddc39ab570473b86-refs/branch-heads/5993@{#1216}) on port 23652
All remote connections are allowed. Use an allowlist instead!
Please see https://chromedriver.chromium.org/security-considerations for suggestions on keeping ChromeDriver safe.
ChromeDriver was started successfully.
2023-10-16 05:46:07.700 ERROR c.k.katalon.core.main.TestCaseExecutor   - ❌ Test Cases/Unified_Agent_Scripts/Workflow_Helping_Scripts/StartBrowserForAgent FAILED.
Reason:
org.openqa.selenium.SessionNotCreatedException: session not created: This version of ChromeDriver only supports Chrome version 118
Current browser version is 117.0.5938.62 with binary path /opt/google/chrome/chrome

I am too much disappointed with the way how Katalon team is fixing the issues which are re-occuring within a month or so. I can’t continue with my testing because none of the avaiable image has same webdriver and chrome versions. This is unacceptable Katalon team.

To me, they are announcing the features but not owning them.

There is another similar problem reported

and a solution suggested by kazurayam but still no news on it as well.

What we do now…!

3 Likes

Hi,

My team has acknowledged this issue and plans to fix it in v9.0.0 next week’s release. We will address this high-frequency issue and try to fix it thoroughly. Please understand our efforts. Hope to help you more. Thank you

4 Likes

do you have the command option “-webui.autoUpdateDrivers=true” in your command line?

1 Like

Yes it is there.

The issue is with browser not the web driver. Katalon docker image has web driver v118 but the browser in same image has v117, browser should be of same version as compared to webdriver for normal working.

1 Like

I have tried other docker tags and saw that each tag has different version. I think that each docker image has a built-in fixed-version browser (Chrome, Firefox and Edge) and a built-in suitable webdriver’s version to run with it. However their webdrivers can be updated to latest with “-webui.autoUpdateDrivers=true”

If you don’t really need the latest webdriver, perhaps you can remove that line and run the script?

1 Like

Hi @Elly_Tran what is the ETA for v9.0.0 ?

2 Likes

Hi,

v9.0.0 can be expected to be within this or next week. Thank you for asking!

2 Likes

So the issue is finally resolved with docker image v9.0.0.

Using Docker executor with image katalonstudio/katalon:9.0.0

Hopefully it will not get break once we have new version of webdriver

2 Likes

Hi everyone, the same issue but with docker katalon v.9.2.0:

Error message: Caused by: org.openqa.selenium.SessionNotCreatedException: session not created: This version of ChromeDriver only supports Chrome version 120.

2 days ago fixed by adding WebDriverManager version update (Chromedriver 114 is resolved for Chrome 116 (using WebDriverManager 5.5.0) · Issue #1115 · bonigarcia/webdrivermanager · GitHub).

Please suggest a solution.
Thanks in advance.

Welcome to the club of the frustrateds.

3 Likes

+1 to the club

I had the same issue in our pipeline with the runtimer. Turning of autoupdate command of and placing a backup of the 120.x driver file back in the directory has resolved the issue for now. Wel untill the sever policy decides to auto update the chrome driver to the new version 122.x then the 120 driver version wil stop working I guess.