Chrome and chromedriver versions

Can anyone tell me which Chrome and chromedriver versions work with Katalon Studio 7.7.0? I’m currently using Chrome 85.0.4183.102 and chromedriver 85.0.4183.87 on a MacBook Pro running High Sierra 10.13.6. I see that there is a chromedriver 86.0.4240.22 but I’m unable to find Chrome 86 anywhere. I’ve already tried using older versions of chromedriver with Chrome 85 and that didn’t work so I downgraded to Chrome 85.0.4183.83 and tried several versions of chromedriver with that, including 85.0.4183.83, and it still didn’t work. So with 7.7.0, I’m unable to use Chrome at all, regardless of versions.

The error I receive is the same one we always get when things are upgraded over at Google.

=============== ROOT CAUSE =====================
Caused by: org.openqa.selenium.SessionNotCreatedException: session not created

For trouble shooting, please visit:

09-21-2020 12:33:21 PM Test Cases/UWorld/Zeqo/Free Trial Enrollments and Upgrades/Free Trial 1/1 Free Trial 1 - Enrollment

Elapsed time: 58.200s

Test Cases/UWorld/Zeqo/Free Trial Enrollments and Upgrades/Free Trial 1/1 Free Trial 1 - Enrollment FAILED.
com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ‘’
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.openBrowser(OpenBrowserKeyword.groovy:81)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.execute(OpenBrowserKeyword.groovy:67)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:73)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.openBrowser(WebUiBuiltInKeywords.groovy:61)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$ Source)
at 1 Free Trial 1 - Free Trial 1 - Enrollment:16)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(
at com.kms.katalon.core.main.TestCaseExecutor.runScript(
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(
at com.kms.katalon.core.main.TestCaseExecutor.execute(
at com.kms.katalon.core.main.TestCaseMain.runTestCase(
at com.kms.katalon.core.main.TestCaseMain.runTestCase(
at com.kms.katalon.core.main.TestCaseMain$runTestCase$ Source)
Caused by: org.openqa.selenium.SessionNotCreatedException: session not created
from disconnected: unable to connect to renderer
(Session info: chrome=85.0.4183.83)
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’
System info: host: ‘RCPARs-MacBook-Pro.local’, ip: ‘fe80:0:0:0:14a5:a687:839e:e638%en0’, ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.13.6’, java.version: ‘1.8.0_181’
Driver info: driver.version: CChromeDriver
remote stacktrace: 0 chromedriver 0x0000000101b0c1b9 chromedriver + 4911545
1 chromedriver 0x0000000101aabe03 chromedriver + 4517379
2 chromedriver 0x0000000101719da6 chromedriver + 773542
3 chromedriver 0x0000000101705bc0 chromedriver + 691136
4 chromedriver 0x000000010171b153 chromedriver + 778579
5 chromedriver 0x00000001016a14b7 chromedriver + 279735
6 chromedriver 0x000000010169d723 chromedriver + 263971
7 chromedriver 0x0000000101677720 chromedriver + 108320
8 chromedriver 0x0000000101678693 chromedriver + 112275
9 chromedriver 0x0000000101ad4f72 chromedriver + 4685682
10 chromedriver 0x0000000101ae2b3a chromedriver + 4741946
11 chromedriver 0x0000000101ae2801 chromedriver + 4741121
12 chromedriver 0x0000000101ab825e chromedriver + 4567646
13 chromedriver 0x0000000101ae3061 chromedriver + 4743265
14 chromedriver 0x0000000101ac9d0a chromedriver + 4640010
15 chromedriver 0x0000000101afc0ba chromedriver + 4845754
16 chromedriver 0x0000000101b12387 chromedriver + 4936583
17 libsystem_pthread.dylib 0x00007fff7936d661 _pthread_body + 340
18 libsystem_pthread.dylib 0x00007fff7936d50d _pthread_body + 0
19 libsystem_pthread.dylib 0x00007fff7936cbf9 thread_start + 13

at org.openqa.selenium.remote.W3CHandshakeResponse.lambda$errorHandler$0(
at org.openqa.selenium.remote.HandshakeResponse.lambda$getResponseFunction$0(
at org.openqa.selenium.remote.ProtocolHandshake.lambda$createSession$0(
at org.openqa.selenium.remote.ProtocolHandshake.createSession(
at org.openqa.selenium.remote.ProtocolHandshake.createSession(
at org.openqa.selenium.remote.HttpCommandExecutor.execute(
at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(
at org.openqa.selenium.remote.RemoteWebDriver.execute(
at com.kms.katalon.selenium.driver.CChromeDriver.execute(
at org.openqa.selenium.remote.RemoteWebDriver.startSession(
at org.openqa.selenium.remote.RemoteWebDriver.<init>(
at com.kms.katalon.selenium.driver.CChromeDriver.<init>(
at com.kms.katalon.core.webui.driver.DriverFactory.createNewChromeDriver(
at com.kms.katalon.core.webui.driver.DriverFactory.startNewBrowser(
at com.kms.katalon.core.webui.driver.DriverFactory.openWebDriver(
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$_openBrowser_closure1.doCall(OpenBrowserKeyword.groovy:74)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:20)
... 17 more


Have you tried the latest Chrome browser and use Tools > Update WebDrivers > Chrome to update the ChromeDriver accordingly ?

Yes, I’ve tried that.

@ThanhTo , is there a way to handle chrome driver versions in katalon dockers? I want to add a parameter for updating chromedriver in command in my docker-compose.yml file…

Does the parameter --config -webui.autoUpdateDrivers=true works?
What i want is that when another user clones and run my project in his machine he is able to run the tests and does not get any issues because he has not installed the chromedriver.


Hi @anuradha

-config -webui.autoUpdateDrivers=true should work for docker too.

Hello @ThanhTo, i am running my tests in a docker. Currently my google chrome version is 84 and chromedriver version is 85 and i think this is the reason why i am unable to open my browser.

How do we make sure that the chrome the docker container is using has a compatible chrome driver to run the tests. Is there a kind of command which can be used?


So fyi, I had to downgrade back to Katalon Studio 7.6.5 in order to get the latest Chrome and chromedriver versions to work on a MacBook Pro running High Sierra.

I am a bit lost tbh. I have added a command in my dockerfile so that my docker use the latest chromedriver but it does not update the chrome the docker is using. How to make docker use compatible chrome and chromedrivers. This issue is making my browser to not open and thus all tests failing. I even installed the latest chrome in the dockerfile but still docker is running old chrome version😴

In the future, it would be best for you to start your own thread for your issue, rather than using someone else’s. Thanks.


Have you tried to remove and re-install both Chrome and Katalon both the latest version to see if that helps ? I think the error message indicates incompatibility issue, which fresh installations should help.

Yes, and that didn’t help. There is definitely an incompatibility issue but removing and reinstalling the latest versions did not help.

okay i have created a new thread with hope that someone atleast replies.

1 Like