Certifications not updating

Ah I see now, I was only using CLI to set-up the agents, but scheduling it normally through testops scheduling…

I followed the tutorial and opened the KRE, put in the correctly generated test suite code, put in the path for the running agent and it worked.

I ran the suite 6 times, 5 exit code 0, 1 exit code 1. so 5 successful 1 unsuccessful.

But now it’s not showing up in my testops…

Where should I find the results then?

and as for the test results on katalon testops:

1 Like

It will show up. Please wait for sometime and it will also be updated on the academy certification dashboard

2 Likes

Awesome, then I’m ready for my journey into the world of API-testing with Katalon.
Thank you for your help and have a great day Monty! :smiley:

3 Likes

Hmm it seems that while its running on the KRE, it isn’t using the agent. If i add the appended code for the agent or not, the actions are the same and the agent isn’t doing anything.

This is my command:
katalonc -noSplash -runMode=console -projectPath=“LOCALPROJECTPATH” -maxFailedTests=3 -retry=0 -testSuitePath=TESTSUITEPATH" -browserType=“Firefox” -executionProfile=“default” -apiKey="APIKEY -testOpsProjectId=1232830 --config -proxy.auth.option=NO_PROXY -proxy.system.option=NO_PROXY -proxy.system.applyToDesiredCapabilities=true -webui.autoUpdateDrivers=true- testOpsAgentType=local -testOpsLocalAgentPath=PATHTO LOCALAGENT\Documents\katalon-agent-win-x64-v1.7.6 -testOpsLocalAgentPort=50001

so it told me to add: testOpsAgentType=local -testOpsLocalAgentPath=PATHTO LOCALAGENT\katalon-agent-win-x64-v1.7.6 -testOpsLocalAgentPort=50001
(I censored PATHTOLOCALAGENT, but it is the correct folder)

if i add it or not, it just runs it through the KRE, and the local agent does nothing. I also dont see the local agent doing anything after checking testops.

last tests I ran on agent were on 3 days ago, so it’s not doing anything today.

agent is up and running, i can schedule tests through testops no problem:

1 Like

I’m also getting more and more confused.
Here I’m being told to schedule the agent on KRE with a command from katalon studio, appended with code that says to use the agent:

"

  1. Download and install Katalon Studio from the Katalon website.
  2. Create a Test Suite or Test Suite Collection in Katalon Studio.
  3. Download Katalon Runtime Engine from the Katalon website.
  4. Go to the Katalon TestOps platform and create a project if you haven’t already.
  5. In your TestOps project, go to “Configurations” and then “Agent Setup”.
  6. Select “Local Environment”, choose your operating system, and download the agent (which will be downloaded as a zip file).
  7. Unzip the agent file to a location on your local machine.
  8. In Katalon Studio, open the “Build CMD” dialog by selecting your Test Suite or Test Suite Collection and clicking on the “Build” button.
  9. Choose your desired browser and platform for the test run, then click “Generate Command”. This will generate a command to run the test in the console.
  10. Copy the generated command to your clipboard.
  11. Open a Command Prompt or Terminal window on your local machine.
  12. Navigate to the directory where you unzipped the agent file.
  13. Paste the command you copied in step 10 into the Command Prompt or Terminal window.
  14. Append the following to the command: “-testOpsAgentType=local -testOpsLocalAgentPath=path\to\agent\file -testOpsLocalAgentPort=50001”. Replace “path\to\agent\file” with the actual file path to the agent you unzipped in step 7.
  15. Press “Enter” to execute the command.
  16. After the test run completes, verify the test results and reports in the TestOps platform.
    "
    But this doesnt do anything with the agent, the appended code does nothing.

and here I’m being told to schedule the test using testops and selecting the local agent

Could somebody clear this up please?

1 Like

go to katalon studio and generate command from the command builder as below and then run it from the runtime engine folder via CLI

3 Likes

That’s what I did last week, multiple times. But it doesnt show my using my localagent on testops if I do this. i did it now aswell, and it just show me that I ran the scripts locally using KRE.

1 Like

I’ve just turned off the local agent, ran the code in the CLI for the KRE again, and it runs the same. so the local agent is not doing anything. so I’m not achieving the “local agent” part of the requirement.

EDIT: all tests pass so everything is working.

1 Like

If you want to run your test using local agent go to your testops–> schedule test run → more options–> local–select agent–save and then run

ensure your agent is running



2 Likes

If you look at my original post you can see I already did 5 tests like you said last week, and they did not count.

I’ve done 5+ tests in the KRE like you’ve instructed me, and I’ve done 5+ tests using a local agent in testops like you’ve shown me, and I did them 3 days ago.
Still both of them are not counting. Hence my original question if I am doing something wrong or misunderstanding what I need to do for the requirement.

1 Like

For some context, I’m talking about this requirement for the certification:

So maybe it’s not updating, since it hasn’t detected my new test cases either.

1 Like

I suggest you to wait for today atleast. It should update

2 Likes

It takes some times(up to 2 days) to update. ,

It’s been 4 days since friday, no updates still.


can u show me ur local agent screenshot once ?

Also after your test suite is completed , is it uploading the reports to TestOps ? Please check this once

1 Like

debug.log (38.6 KB)
log from last test in attachment.
Yeah, all tests are uploaded to testops now.

agent here:

Hi @leyssm1,

Thank you for your interest and participation in the Katalon Certification Program. For your issue, I will go and check with the team to ensure the tracking system is still working fine. Will keep you posted on this.

In the meantime, could you list the detailed steps you did for this requirement? I understand it’s kind of frustrating when we get stuck. But if you could record the screen and the steps, it would be great and super helpful (to make sure everything is done correctly).

2 Likes