Can't set the Content-Type

I want to do an API test,but the Japanese displayed in the response is scrambled ,I tried to add content-Type,but it didn’t solve the problem of scrambling.


1 Like

Would you mind sending us the request file (.rs file). We will have more clues to investigate the issue.

Excuse me ,Where can i find .rs file ?

Besides,this preoblem only appears in Windows,Mac won’t


This seems to be an issue with rendering CJK characters (the screenshot said charset=Shift_JIS).

@244401716 how was it rendered if you remove charset part?

If I remove the charset ,the result is the same as the screenshot

I thought it was a charset problem at first ,but in mac,i did API test ,the Japanese part is not scrambled (charset is not set :charset=Shift_JIS,default charset=UTF-8)


Is it possible for you to disclose the URL of your application under test to use?

There are many factors that can cause garbled characters. Therefore we require immediate access to the UAT, otherwise it would be hard to figure out the cause.

All URLs with Japanese are scrambled like this


Let me tell you what I saw, and my thought.

I opened using Katalon Studio API testing UI. The following screenshot shows that the CJK characters in the response body are rendered garbled.

I opened using Chrome.

The page was encoded in UTF-8, and find the original text is:


I tried to reproduce gabling the UTF-8 encoded characters.
I used

This interesting tool enabled me to render UTF-8 encoded characters mistakenly as MS932(=SJIS).

The gabled characters reproduced matches exactly with the gabled characters in Katalon Studio.

This proves that, Katalon Studio has a problem rendering the UTF-8 encoded characters. Katalon Studio does not respect the charset expressed by the HTTP Response Header Content-type text/html, charset=UTF-8. It seems rendering the response body with the System’s default charset.

Eclipse=Katalon Studio has preference setting for the text file encoding. I checked it.

The preference is set to be UTF-8. However, I believe KS does not respect this setting as well. KS is rendering the Web API Response body always with Default(MS932). This is a problem to be fixed.

Windows PC in Japan has the default encoding to be MS932. But Mac in Japan has the default encoding to be UTF-8. This difference would be the reason why @244401716 says on Mac OK, on Windows NG.

There are many other posts about the same issue

@devalex88, @Dung_Ngo, @ThanhTo

Do you recognize this issue as a problem of Katalon Studio?

The issue list of katalon studio seems to be unaware of this issue.

hello,guys. I had the same problem.Recently I have found a solution to this problem
So, you can try the following solution:
1.Add Windows system environment variables
path:-Dfile.encoding=UTF-8 it
3.restart your Katalon Studio,

If the above steps are not detailed enough, you can visit my blogtestclass.I wrote the detailed instructions, but I used Chinese to write.
Before configuration modification:

After configuration modification:

u see it works :grinning:



@devalex88, @Dung_Ngo, @ThanhTo

Thank you all for this great feedback. This issue will be addressed in KS 7.0.

really helped me