Autocomplete doesn't work in script modee

Hello everyone

I’ve been using Katalon Studio version 7.9.1 (build 208) on MacOS Catalina 10.15.7 and I’m experiencing issues with the autocomplete feature of Katalon.

At company where I work, we use parametrised tests and every time I try to use autocomplete to fill in variable name it cuts part of the name of that variable (usually part which I’ve already typed in). Due to this, feature is causing issues (due to missmatch in variable names) and it makes feature less efficient.

Here is a video of how it looks: katalon-issue.mov.zip (1.8 MB)

Does anyone know how could I resolve this issue?
Thanks in advance
Ivica

Using enhancedClick() & sendKeys() might work to slow down your text input.
To use sendKeys() open ‘Script’ view & place “import org.openqa.selenium.Keys as Keys” at the end of the import section.

import ...
import org.openqa.selenium.Keys as Keys

//Test case body:
//enhancedClick() & sendKeys(), example:
WebUI.openBrowser('')
WebUI.navigateToUrl('www.google.com')
def SearchText = 'Msn'
WebUI.waitForElementVisible(findTestObject('YourSearchInputObject'), 30)
WebUI.enhancedClick(findTestObject('YourSearchInputObject'))
WebUI.sendKeys(findTestObject('YourSearchInputObject'), SearchText)

//Test case body:
//OR waitForElementVisible() & WebUI.setText() might also work...
WebUI.openBrowser('')
WebUI.navigateToUrl('www.google.com')
def SearchText = 'Msn'
WebUI.waitForElementVisible(findTestObject('YourSearchInputObject'), 30)
WebUI.setText(findTestObject('YourSearchInputObject'), SearchText)

@Dave_Evers

Thank you for the reply.

I’m not experiencing the issue with Katalon selecting keys during execution of my tests, but rather with autocompletion (intenseness) in Katalon Studio IDE.

Hi @ivica, performance improvement is what it sounds like you want. I would like Katalon to be more responsive as well. The only work-around I have is to wait and type slower. The dropdown list will appear in full after pressing dot (.) if you wait.

I have to wait 1/2 second to 1 second. It can be annoying for sure. How long is your wait?

@ivica

I too have to slow my input at times, for example:

@jim.sears
My issue is a bit different. I’m aware that sometimes it can take up to second or two for the list to display.

However, my issue is with selection of the offered item in the list. Once offered items list is displayed and I select the offered option, Katalon Studio IDE cuts off part of my variable name (the part of the string which I’ve inputed before asking for suggestion).

Hi @ivica,

That is definitely a bug. Not to long ago, a few of us had issues with autocomplete not working and I modified the Eclipse settings. I wonder if you set and/or reset your eclipse settings if if would fix your bug.

Good luck!