Your connection is not private message when using chrome to run test cases- Katalon 7.2.1

Please help !

Looks like your cert has expired?

Hi @rajishi,
There may be many reasons for your issue. Please help to clarify:

  • Have you encountered this issue before?

  • Have you configured your system proxy to use a HTTPs proxy?

In the meantime, there is a quick and dirty way to workaround it. You may need to add --ignore-certificate-errors to Chrome options to ignore these kind of certificate errors. Try to see if that helps.

Hi huynguyen,

thank you for your response. I tried setting the chrome options under project settings. That did not fix it.
I started getting this error soon after i upgraded Katalon to version 7. I do not get this error when i try to access the url directly from chrome, Vs from Katalon.

I have not configured system proxy to user HTTPs proxy. How do i do that ?

thanks in advance.

Hi @rajishi,
Did you configure proxy in Katalon preferences? If the answer is yes, please show the screenshot of your proxy configuration

I set the following under project->settings and it worked. Thank you.

Hi, this is the one that works for me:

ignore-certificate-errors

Project --:settings --:Desired capabilities–:WebUI–:Select Browser
acceptInsecureCerts | Boolean | true

Below video helped me.

Is this all accepted by all browsers ?

It’s a message from your browser that informs you that the connection is not secure. The most common cause of “Your connection is not private” is an incorrect date & time set on your PC. Chrome makes sure that your computer’s clock matches the clock in a Google server farm, and if it doesn’t, will block the connection to HTTPS sites for security reasons.

To fix your issue, set your computer’s clock to the correct current time.

  • Go to System Preferences
  • Choose Date & Time
  • Navigate to the Date & Time tab
  • Change the current time to the correct time (accurate to the nearest minute will do).

If it’s not your computer’s fault, it’s just a Chrome security feature. Chrome detects malicious activity going on with the site (like malware-laced ads, breach by hackers, etc.) and automatically warns you to protect you if it believes your security or safety might be at risk. If you want to override the warning, just hit Advanced -> Continue to site.