Wrong syntax error

I get the unable to execute the current test error and all i see in the details is wrong syntax. this is the sample katalon test project. i am not sure if i did something weird

1 Like

usually yes, you can prove me wrong by posting more details so we can actually take a look on your issue…

I am just running the sample web test from katalon, i have not made any changes to the script

I’m getting the same issue - trying to run any of the sample test cases, or a simple test case opening a URL, all I get is a message saying ‘Unable to execute the current test case. Reason: Wrong Syntax’

Is there a solution to this? Or can someone point out what might be wrong?

Patrick,

Could you take screenshot of Katalon Studio where the message 'Unable to execte …" is displayed, and post it here?

I’m also getting the same error after updating the katalon to 6.1.3 (latest version).

1 Like

Please send us the log file and click the details button to retrieve more info about the issue.

Warning: NLS missing message: MSG_FORUM_SEARCH in: com.kms.katalon.constants.messages
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/TempTestSuite1543480098495.groovy: 6 Groovy:unable to resolve class groovy.lang.MissingPropertyException
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/TempTestSuite1543485542671.groovy: 6 Groovy:unable to resolve class groovy.lang.MissingPropertyException
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/TempTestSuite1543488496988.groovy: 6 Groovy:unable to resolve class groovy.lang.MissingPropertyException
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/TempTestSuite1545288708084.groovy: 6 Groovy:unable to resolve class groovy.lang.MissingPropertyException
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/TempTestSuite1547616935379.groovy: 6 Groovy:unable to resolve class groovy.lang.MissingPropertyException
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/TempTestSuite1548135561572.groovy: 6 Groovy:unable to resolve class groovy.lang.MissingPropertyException
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/TempTestSuite1552460491264.groovy: 6 Groovy:unable to resolve class groovy.lang.MissingPropertyException
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/CustomKeywords.groovy: 8 Groovy:unable to resolve class com.click.util.clickTap
/C%%Users%System02 21032018%Katalon Studio%MarginPoint_AndroidApp%MarginPoint_AndroidApp.prj/Libs/CustomKeywords.groovy: 8 Groovy:unable to resolve class com.click.util.clickTap
SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Warning: NLS unused message: Key in: com.kms.katalon.composer.webui.constants.composerWebuiMessages
Warning: NLS missing message: DIA_CONFIRM_INSTALL_WEBDRIVER in: com.kms.katalon.composer.webui.constants.composerWebuiMessages
Warning: NLS missing message: DIA_CONFIRM_INSTALL_WEBDRIVER_TITLE in: com.kms.katalon.composer.webui.constants.composerWebuiMessages

i have same problem when running mobile test case :frowning:

Warning: NLS missing message: MSG_FORUM_SEARCH in: com.kms.katalon.constants.messages
16:23:47.528 [Worker-1] DEBUG org.eclipse.jgit.util.FS - readpipe [git, --version],C:\Program Files\Git\cmd
16:23:47.630 [Worker-1] DEBUG org.eclipse.jgit.util.FS - readpipe may return ‘git version 2.20.1.windows.1’
16:23:47.630 [Worker-1] DEBUG org.eclipse.jgit.util.FS - remaining output:

16:23:47.883 [Worker-1] DEBUG org.eclipse.jgit.util.FS - readpipe [git, config, --system, --edit],C:\Program Files\Git\cmd
16:23:48.285 [Worker-1] DEBUG org.eclipse.jgit.util.FS - readpipe may return ‘C:/Program Files/Git/mingw64/etc/gitconfig’
16:23:48.285 [Worker-1] DEBUG org.eclipse.jgit.util.FS - remaining output:

SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Warning: NLS unused message: Key in: com.kms.katalon.composer.webui.constants.composerWebuiMessages
Warning: NLS missing message: DIA_CONFIRM_INSTALL_WEBDRIVER in: com.kms.katalon.composer.webui.constants.composerWebuiMessages
Warning: NLS missing message: DIA_CONFIRM_INSTALL_WEBDRIVER_TITLE in: com.kms.katalon.composer.webui.constants.composerWebuiMessages

3 Likes

Can anyone please help me… i am also facing same issue with Katalon 6.1.3.

Getting Wrong Syntax warning while running test case on Android platform…

@Pooja1 I was with the same issue I tried everything. Just abandon 6.1.3. Go back to 6.1.0, it works fine

1 Like

Thanks @nosi.mobile I have just upgraded to 6.1.4 and also updated JAVA with and that warning resolved.

But now i am unable to start my app on Android mobile ( which working fine in earlier versions).

@Pooja1 go to developer options on android and try to revoke access and give it again. Are PC and Android device behind the same wifi? Spy Mobile works?

Hello dear,
could you see with me this issue, i run the test suite, but not working as before.

@ferrariklersone Perhaps just shut down KS and restart it. See if that fixes your issue.

it doesn’t work despite restarting.

I don’t know what happened.

Are you using a “data file” that you may have renamed or did you rename a TC?

Did you recently change your password? (check if you may not have permission to access the project folder). If you are working in a corporate environment, check with your Network Engineers/Analysts to see if they have done or installed something.

I had issues, some were related to my hardware, others were Katalon’s configuration.
But i downloaded new KS, i opened my current project and everything is working well now.

So thank you for your feedback everytime.

:slight_smile: