Unable to open project. Reason: InterruptedException

java.lang.InterruptedException: System could not generate internal.GlobalVariable file normally. Please check your writable permission in folder: C:\Users\dinba\Katalon Studio\dev.
at com.kms.katalon.controller.GlobalVariableController.waitForGlobalVariableClassFileAvailable(GlobalVariableController.java:82)
at com.kms.katalon.controller.GlobalVariableController.generateGlobalVariableLibFile(GlobalVariableController.java:67)
at com.kms.katalon.controller.ProjectController.openProjectForUI(ProjectController.java:102)
at com.kms.katalon.composer.project.handlers.OpenProjectHandler$1.run(OpenProjectHandler.java:165)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)

One thing that always worked for me when the project wont open, just delete the .project file and try again…

The same problem with me!


I tried to delete .project, restart under administrator etc. Nothing works.

надо поменять местоположение папки каталон. ТОгда заработать должно, у меня таким способом заработала

Google Translate :
Sie müssen den Speicherort des Catalon-Ordners ändern. Dann sollte es verdienen, es hat bei mir so geklappt.

I put both folders (with Katalon itself and with Kalalon’s projects) in C:\ (just root).
Now it opens projects and creates new ones.

I’m sorry,I forgot to write in English, automatically answered in Russian