Unable to open browser with url:

Hello Team,
I am using latest version of katalon studio. i am getting the below mention error while run the script.

Starting ChromeDriver 2.33.506120 (e3e53437346286c0bc2d2dc9aa4915ba81d9023f) on port 29928

Only local connections are allowed.

01-19-2018 09:56:59 PM - [FAILED] - Unable to open browser with url: ‘’ (Root cause: org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited normally

(Driver info: chromedriver=2.33.506120 (e3e53437346286c0bc2d2dc9aa4915ba81d9023f),platform=Windows NT 6.1.7601 SP1 x86_64) (WARNING: The server did not provide any stacktrace information)

Command duration or timeout: 61.87 seconds

Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘2017-11-06T21:07:36.161Z’

System info: host: ‘HVDIVD15CAF1388’, ip: ‘135.213.250.4’, os.name: ‘Windows 7’, os.arch: ‘amd64’, os.version: ‘6.1’, java.version: ‘1.8.0_102’

Driver info: driver.version: CChromeDriver)

01-19-2018 09:56:59 PM - [END] - End action : openBrowser.

Please let me know the solutions for this

thanks,
Regards,
sheker

Hi sheker,

Please try upgrading chromedriver to latest version followed by below steps:

  • **Download **preferred Chromedriver here
  • Copy downloaded Chromedriver and paste into Katalon Studio folder
    • \configuration\resources\drivers\chromedriver_win32
    • \configuration\resources\drivers\chromedriver_win64

Hi Sheker,
Did the above suggestion work for you?
I am facing the same issue but hasnt got resovled. Please let me know…

We have exactly the same problem! Unable to run Katalon via a bat file (command line).
And after replacing the chromedriver with a more recent one, the problem still persists.
It states that
Test Cases/Folders/folders FAILED because (of) Unable to open browser with url: ‘https://our-team/qa/index.html’ (Root cause: java.lang.IllegalAccessError: tried to access method com.google.common.util.concurrent.SimpleTimeLimiter.(Ljava/util/concurrent/ExecutorService;)V from class org.openqa.selenium.net.UrlChecker)

It works fine with the Katalon version 5.0.1 but not with the more recent ones.
This causes a problem with TeamCity execution also.
Vinh Nguyen said:

Vinh Nguyen said:

Hi sheker,

Please try upgrading chromedriver to latest version followed by below steps:

  • **Download **preferred Chromedriver here
  • Copy downloaded Chromedriver and paste into Katalon Studio folder
    • \configuration\resources\drivers\chromedriver_win32
    • \configuration\resources\drivers\chromedriver_win64

Based on this solution: https://stackoverflow.com/questions/23957409/ava-lang-illegalaccesserror-tried-to-access-method-com-google-common-collect-ma, I think you need to downgrade current guava library into version 22.0

1. Download this file: http://central.maven.org/maven2/com/google/guava/guava/22.0/guava-22.0.jar
2. After downloaded, rename it to: com.google.guava_22.0.0.jar
3. Navigate to plugin folder of Katalon Studio, e.g: \plugins
4. Delete com.google.guava_23.0.0.jar file within that folder
5. Copy renamed file from step #2 into plugins folder instead
6. Rename it back to be com.google.guava_23.0.0.jar

Please let me know if this workaround solution works for you

Did the earlier version of the google.guava_22.0.0.jar file work? I am having the same error as above with firfox

Hi All,

I also having the same problem and it is on Linux Katalon v5.3.1.
Have tried @Vinh Nguyen solution (using guava 22) but still not works.

Have you tried to execute using Chrome (headless)?

Vinh Nguyen said:

Have you tried to execute using Chrome (headless)?

Tested using Chrome (headless) as well. Still having the same problem.

Hey there,

Any solution to this as yet?

I also get this, Starting ChromeDriver 2.35.528161 on port 32800

Only local connections are allowed.

Basically the Chrome browser opens but then nothing happens. Got all latest drivers as well for katalon and Chrome.

1 Like

You might have incorrect proxy setting in Katalon. Try going to Window>Katalon Studio Preferences>Katalon>Proxy. The default Proxy Option is No Proxy, but if you set it to **Use system proxy configuration **that may help.

3 Likes

Britte Genzlinger said:

You might have incorrect proxy setting in Katalon. Try going to Window>Katalon Studio Preferences>Katalon>Proxy. The default Proxy Option is No Proxy, but if you set it to **Use system proxy configuration **that may help.

Thank you very much Britte! I was knocking my head on the table since long time to understand why none of the browsers were working as expected. But this suggestion solved my issue…the problem was my organization proxy and it was not picked by Katalon, since it was set to No Proxy by default! Now it works like charm!

1 Like

Vinh Nguyen said:

Based on this solution: https://stackoverflow.com/questions/23957409/ava-lang-illegalaccesserror-tried-to-access-method-com-google-common-collect-ma, I think you need to downgrade current guava library into version 22.0

1. Download this file: http://central.maven.org/maven2/com/google/guava/guava/22.0/guava-22.0.jar
2. After downloaded, rename it to: com.google.guava_22.0.0.jar
3. Navigate to plugin folder of Katalon Studio, e.g: \plugins
4. Delete com.google.guava_23.0.0.jar file within that folder
5. Copy renamed file from step #2 into plugins folder instead
6. Rename it back to be com.google.guava_23.0.0.jar

Please let me know if this workaround solution works for you

Hi Vinh Nguyen, seems like this solution is also not working. Any other ideas ? I compared the ‘Plugins’ folder in both Katalon 5.0.1 and Katalon 5.3.1 and they of course are not similar but in 5.3.1 there is no such a file named guava_22 or guava_23.

1 Like

I downgraded the guava version to 19 and works fine.
Download here: http://central.maven.org/maven2/com/google/guava/guava/19.0/guava-19.0.jar
and follow Vinh Nguyen’s steps.

No, the issue is not resolved. when i tried the steps mentioned above. Not launching the katalon tools now. Throwing the attaching error log inside configuration folder.
---------------steps—
1. Download this file: http://central.maven.org/maven2/com/google/guava/guava/22.0/guava-22.0.jar
2. After downloaded, rename it to: com.google.guava_22.0.0.jar
3. Navigate to plugin folder of Katalon Studio, e.g: \plugins
4. Delete com.google.guava_23.0.0.jar file within that folder
5. Copy renamed file from step #2 into plugins folder instead
6. Rename it back to be com.google.guava_23.0.0.jar *** try guava 19 version also
------------------------------------------------

1528810435780.log

I was receiving the same error, attempting to run a test suite from command line. None of the above worked for me. I finally resolved it by updating my Selenium Webdriver version in External Libraries. I had a Selenium Standalone jar of 3.9.1. I added the newest one - 3.13.0 and added it to my External Libraries (Project Settings\External Libraries\Add) Maybe that will work for somebody else. Thanks

Bhavesh Agarwal said:

Britte Genzlinger said:

You might have incorrect proxy setting in Katalon. Try going to Window>Katalon Studio Preferences>Katalon>Proxy. The default Proxy Option is No Proxy, but if you set it to **Use system proxy configuration **that may help.

Thank you very much Britte! I was knocking my head on the table since long time to understand why none of the browsers were working as expected. But this suggestion solved my issue…the problem was my organization proxy and it was not picked by Katalon, since it was set to No Proxy by default! Now it works like charm!

yes it work for tests that run in Chrome but not in Firefox. already update selenium IDE as Firefox’s add on but still not work.

Same for me. Worked like a charm.

I hit the same issue and this is the solution for me.
Thanks!

this works,
thank you

:smile: