Unable to install appium@1.8.1 through npm

appium1.9 is working for me, as it doesn’t allow to capture objects I tried to install appium 1.8.1 but getting some error. (below is the error)

C:\Users\A1001515>npm install appium@1.8.1

npm WARN deprecated appium-android-bootstrap@2.11.0: Moved to appium-android-dri


npm WARN deprecated appium-uiautomator@1.2.0: Moved to appium-android-bootstrap

> appium-chromedriver@4.0.0 install C:\Users\A1001515\node_modules\appium\node_m


> node install-npm.js

info Chromedriver Install Installing Chromedriver version ‘2.38’ for platform 'w

in’ and architecture ‘32’

info Chromedriver Install Opening temp file to write chromedriver_win32 to…

info Chromedriver Install Downloading https://chromedriver.storage.googleapis.co


RequestError: Error: connect ETIMEDOUT

** at new RequestError (C:\Users\A1001515\node_modules\appium\node_modules\requ**


** at Request.plumbing.callback (C:\Users\A1001515\node_modules\appium\node_mod**


** at Request.RP$callback [as _callback] (C:\Users\A1001515\node_modules\appium**


** at self.callback (C:\Users\A1001515\node_modules\appium\node_modules\request**


** at emitOne (events.js:116:13)**

** at Request.emit (events.js:211:7)**

** at Request.onRequestError (C:\Users\A1001515\node_modules\appium\node_module**


** at emitOne (events.js:116:13)**

** at ClientRequest.emit (events.js:211:7)**

** at TLSSocket.socketErrorListener (_http_client.js:387:9)**

** at emitOne (events.js:116:13)**

** at TLSSocket.emit (events.js:211:7)**

** at emitErrorNT (internal/streams/destroy.js:66:8)**

** at _combinedTickCallback (internal/process/next_tick.js:139:11)**

** at process._tickCallback (internal/process/next_tick.js:181:9)**

npm WARN enoent ENOENT: no such file or directory, open 'C:\Users\A1001515\packa


npm WARN A1001515 No description

npm WARN A1001515 No repository field.

npm WARN A1001515 No README data

npm WARN A1001515 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fse


npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@

1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”}



npm ERR! errno 1

npm ERR! appium-chromedriver@4.0.0 install: `node install-npm.js`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the appium-chromedriver@4.0.0 install script.

npm ERR! This is probably not a problem with npm. There is likely additional log

ging output above.

Can you help me?? As, I have to represent demo of mobile testing through Katalon in my company for other teams.

why would be this a katalon issue?

looks more like an npm related problem …

hv u uninstalled the 1.9 version?

I am saying its a katalon issue. Just asking for help

@Gradito Tunggulcahyo
Yes… but still same error…

Hi Meenal,

Do you know if you’re behind a corporate firewall? If so, the issue might be that you need to allow proxying. There is a discussion here that might help:


- Chris

Hi @Meenal_Kawatra,

It’s been awhile, so not sure if you’re still having problems with Appium. However, if you’re having trouble installing Appium via npm due to Chromedriver issues, you can download the Appium Desktop installer. Note that the version of the Desktop doesn’t line up with the actual version of Appium, so you’ll need to get Appium Desktop 1.6.3 (includes Appium 1.8.1) in order to support Katalon Studio 5.10.1:

Hope this helps,