Failed on appium installation from command ‘npm install -g appium’

Hi, I wanna ask u about appium installation. I have some problem to
install appium with command ‘npm install -g appium’ and its shown a
message such as ‘ENOENT: no such file or directory’ in many rows, which
is caused the installation failed in the end. I tried to check it with
appium -v and there is nothing because the installation just failed. I also tried to clear cache first but its not worked.

I already tried to install appium desktop application
from appium setup (not from cmd), but it looks no used since it didn’t
work with the katalon somehow. Is it a problem because I used appium
desktop setup, so it must be from ‘npm install -g appium’ command? Or
there is something else here? I need your help to solved my problem.
Thanks

For your info, I am using windows 10 64 bit, node v8.9.4, and npm 5.6.0. The katalon version is 5.3

by the way, here is the error message

1.png

2.png

This is an issue of npm, not related to Katalon Studio yet. Have you tried some suggested solutions from here?

Regards

Hi Alex, thanks for your response.
I know this was about the npm install (in this case was appium). I think i need it to make an automation for mobile, so I think some people here can help me to solved mine.

I already tired all of suggestion from the link u gave me, but it still not worked for me. I posted this question because the guideline to prepare node and appium installation just simple as it, but i have a lot of problem which is not easy as what the guideline said. any idea to install this appium for mobile automation?