Unable to find the element located by 'By.xpath:

Hey there,

I have a window in which there are filling fields (first name, family, etc.)

when I run, the “KATALON” does not recognize these fields,

I tried through the spy web and it did not help either,

does anyone have an idea? a big thanks

1 Like

Please share the HTML of your page, your Katalon script and any error logs that you might have.

I have the same problem when run New Sample Project ( Sample JIRA UI Tests Project) on Katalon Studio Version 5.10.1.
Here are screenshot from this error:

@Broto_Winarno Could you please copy and paste the text of the error, html, and while you’re at it, add the script code (from the “</> Script” tab).

WebUI.callTestCase(findTestCase(‘Simple Examples/Login Test/Test data hardcoding examples/Login with username and password specified in the test steps’),
[:], FailureHandling.STOP_ON_FAILURE)

WebUI.waitForElementClickable(findTestObject(‘Test Objects/Pages/Master Page/Menu/elCreate’), 50, FailureHandling.OPTIONAL)

WebUI.click(findTestObject(‘Test Objects/Pages/Master Page/Menu/elCreate’))

WebUI.waitForElementVisible(findTestObject(‘Test Objects/Pages/Create Issue Page/elRoot’), GlobalVariable.element_timeout)

WebUI.verifyElementText(findTestObject(‘Test Objects/Pages/Create Issue Page/elTitle’), ‘Import issues\nCreate issue’)

CustomKeywords.‘com.jira.components.JSelect.selectByText’(‘Project’, ‘Katalon-Demo (KD)’)

CustomKeywords.‘com.jira.components.JSelect.selectByText’(‘Issue Type’, ‘Bug’)

String time = new Date().getTime()

Script error when execute : CustomKeywords.‘com.jira.components.JSelect.selectByText’(‘Project’, ‘Katalon-Demo (KD)’)

One of the problems is that the text in screenshots is barely legible, that’s why I asked can you copy and paste text. :slightly_smiling_face: :nerd_face:

However, it seems your test is failing on the third step: WebUI.click(findTestObject(‘Test Objects/Pages/Master Page/Menu/elCreate’)).

So, please copy and paste the text of the error log together with the HTML of the element (the one you already posted the screenshot of).

Hi Good day, i’m doing a Spy Web but still i encountered error and it says "Unable to find the element located by ‘By.xpath: //input[@type=‘checkbox’]’. Please recheck the objects properties to make sure the desired element is located. "