Unable to execute katalon test suite in Jenkin

Kalalon command line execution getting stuck when I ran from Jenkin. below is the jenkin log

C:\Program Files (x86)\Jenkins\workspace\sample_Katalon_5.4.1>cd C:\katalon_5.4.2\Katalon_Studio_Windows_64-5.4.2\Katalon_Studio_Windows_64-5.4.2\ C:\katalon_5.4.2\Katalon_Studio_Windows_64-5.4.2\Katalon_Studio_Windows_64-5.4.2>katalon -noSplash  -runMode=console -projectPath="C:\Program Files (x86)\Jenkins\workspace\sample_Katalon_5.4.1\rdqa_bau_pnb.prj" -retry=0 -testSuitePath="Test Suites/Smoke_Suite" -executionProfile="QA_Environment" -browserType="Chrome" -reportFolder="C:\Program Files (x86)\Jenkins\workspace\sample_Katalon_5.4.1\Reports" Request sent successfully.

after “request send successfully” message, it is getting stuck. I am getting same issue when I used latest 5.6 version. So, please help me to resolve the issue.


I am getting something similar. I configured Jenkins to run a test suite after a build is complete however Jenkins is unable to complete this build step. Can someone help.


The answer to my question was in the instructions. See below.

Note: the command should NOT include the -noExit and -consoleLog parameters so that CI logs can be displayed directly on the job view.

We are not using -noExit or -consoleLog parameters however it is getting struck in the build step. The Jenkin job was working fine earlier (in Katalon 5.4.1) but, it is not working fine after upgrading latest katalon version in Jenkin server.

So, could you please help to resolve the issue?

I have the same error for the last release but i see it in 5.4.1 version too.
Even without parameters I can’t start Katalon with Jenkins.

Did anyone resolve this issue?



When you encounter the problem (katalon does not start), you may find some diagnostic in the following file : \config\.metadata\.log

For your specific case the path would be:

  • D :\Katalon\Katalon_Studio_Windows_64-5.4.1\config\.metadata\.log

Please check the .log file. Do you find any interesting messages such as JavaStrackTrace?

First of all, Can you not update to latest version of Katalon?

Unable to execute Katalon suite in command line and it is getting hanged after " request sent successfully." Attached screenshot for the same. I am facing the same issue even when I ran from Jenkin. The same was working fine when I used 5.4.2 version.
Also, I see the below warning message in .log file under katalon folder.


Warning: NLS missing message: INCLUDE_SCRIPTS_FOLDER in: com.kms.katalon.constants.globalMessages



So, Can you please help to resolve the issue?



In the cmd.exe console, i see a line like:

C:\Katalon_Studio_Windows_64-5.6.0\Katalon_Studio_Windows_64-5.6.0>C:\Katalon_Studio_Windows_64-5.6.0\Katalon_Studio_Windows_64-5.6.0>katalon -noSplash -runMode=console ...

I can not understand this line. Too much unusual. There must be some mistake here.

Also in the cmd.exe console, you can find a message saying:

'C:\Katalon_Studio_Windows_64-5.6.0\Katalon_Studio_Windows_64-5.6.0' is not recognized as an internal or external command, operable program or batch file.

I suppose you should be able to find out the reason yourself.

Hi Kazurayam,

It seems there is no issue in the Katalon command line and it is launching Katalon window with “request sent successfully” message. But it is hanged after that. I have attached new screenshot for your reference
We are not able to proceed further due to this issue and not able to do Jenkin integration due to this issue. It was working fine earlier but not working fine now. Also, we tried in different machines however, not working



don’t know if you have overcome this issue. I had it too on the 5.9.1.

After a few days of debugging and investigation, i discovered that my issue was related to having a folder on the test cases named “Configuration”. As soon I changed the folder name the problem was gone.

Check with a clean project (only with a dummy test case) if it runs and after that start adding small chunks of your project code to see if it breaks.


Generally a in CI configuration, the checked out automation project should be clean and fresh. That means in your configuration, please add some kind of Clean Workspace mechanism first before any checkout action to ensure a clean Katalon project state. Within this state, you can avoid any unexpected execution behaviors in the future.

Thanks Sandro! it is working fine after changing the folder name from configuration to some other name under test case. Thanks for your help!

Thank you @Sandro_Santos. @Alice please verify if this is a bug.