Unable to clear browsing data in chrome version 73.0.3683.86 using katalon

In chrome version 73.0.3683.86 , I am trying to clear browsing data.
For this I have tried in many ways

  1. find element by css selector
    2)Using Robot class keypress
    3)Using Actions class send keys
    But not able to click clear data button in ‘chrome://settings/clearBrowserData’.

When I tried executing the same script in chrome version 63.0.3239.132, the button click is working fine.

Can anyone suggest how to clear browsing data using katalon for the specified chrome version?

What error are you getting when you run you script and what steps do you take? please share more information so we can help further

Steps taken:
driver.findElement(By.cssSelector(’*/deep/ #clearBrowsingDataConfirm’)).click()

Unable to locate element: {“method”:“css selector”,“selector”:"*/deep/ #clearBrowsingDataConfirm"}
(Session info: chrome=73.0.3683.86)

So its telling you that it cant find the element, so something must be up with your css. Could you share the html of the element you are attempting to click on. Then as its css, we can get @Russ_Thomas to take a look. Much better with css than me.

did a quick look on chrome 75.x and looks like the selector should be without */deep …

Thks lbus , but i have tried without */deep also , It is unable to click the button.

Instead of css selector , I have tried by link text also. Still unable to perform clear data button click.
driver.findElement(By.linkText(“Clear Data”)).click();

Can anyone suggest solution for this?

When you say unable to click, is the error remaining the same as before? or are u getting a different error now.

Please, like i said, share the html of the exact element you are attemtpting to click on. It will help us help you :slight_smile:

you may need and ‘waitforelement’ before. from what i saw, it takes some time until the modal is shown

even if i am increasing delay time…it is not able to locate. I think my chrome version is not allowing to control chrome settings. Because when I tried the same script in chrome version 63.0.3683.86 it is working.
So I need some solution which could work in my chrome version

I am getting same error.
I have took screenshot of html element