Trying to use the Runtime Engine

Trying to test the runtime engine before hiding it behind our Jenkins. When I run

 katalonc -noSplash -runMode=console -projectPath="C:\Projects\Katalon\katalon.prj" -retry=0 -testSuitePath="Test Suites/JR Test" -executionProfile="default" -browserType="Edge" -apiKey="keyhere"

It all seems to try to start then I get

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:

file:/C:/Projects/Katalon/Scripts/ClipSelectStart/Script1572885519716.groovy: 4: unable to resolve class
@ line 4, column 1.

file:/C:/Projects/Katalon/Scripts/ClipSelectStart/Script1572885519716.groovy: 3: unable to resolve class
@ line 3, column 1.

2 errors

The test file has the imports on the line specified and this all works as expected when run manually in Studio.

So what am I doing wrong?


try a different browser. with Edge … it’s a full story

Try adding these lines to your batch script:

REM Clean up first ...
rd /S /Q "<katalon-project-path>\Libs"
rd /S /Q "<katalon-project-path>\bin"
del "<katalon-project-path>\.classpath"
del "<katalon-project-path>\.project"

katalonc -noSplash ...

Done this but it doesn’t get me any further - just a different error message. The error occurs on the line:


and says:

java.lang.NoClassDefFoundError: org/openqa/selenium/WebElement

It’s as if it can’t access anything in the org/openqa/selenium namespace as I also see lots of warnings about it being unable to resolve classes in that namespace before the actual failure.

I’ve just found the log file for a run and this mentions a lot of groovy errors the first of which says it is in the ‘semantic analysis’ phase. I’ll upload the whole log file if anyone is interested but I’m no further on and my trial licence for Runtime is ticking.
If I don’t manage to get this working soon then I can’t recommend that we continue using Katalon at all. It’s rather key that we can run the tests from the command line in our Jenkins build pipelines.

try -browserType=“Chrome” and send us the log file if you still see the error that stop your script running

RunLog.log (57.1 KB) Doesn’t seem to matter which browser I use the error(s) are the same. I’ll attach the .log file for this latest run. Had to rename the file as the upload rejected the name ‘.log’.

Can you try running your script on the machine that you set up Jenkins pipeline by KS tool, @jrichards?

Sorry for the delay, been off work.
I have installed the latest Runtime Engine on our build server, and run from the command line. I am still at at the stage of proving that this is even possible before scripting it into Jenkins. The tests now appear to run although both of them fail. I’ve talked to our Test engineer and we tried running the tests manually through KS. These tests worked where the same tests in Runtime Engine failed.
Also don’t know why this works on the build server (Win server 2016) but not on my Win 10 desktop.
I also experimented with using the properties file and found that you can’t have the project path or api-key in that file. Run fails if you do - but that is a different problem.