There was problem while parsing the response object

I have a problem when calling api with method POST.
I tried to call this api in Postman and it works. But when I try to call in Katalon, there is a problem like the following picture:
The response status is 200 but body having wrong font like this:

Header and body are the same, but I don’t know why katalon can not return the expected response.
I hope everyone can help me to resolve this problem.
Thank you so much!

looks like you received a gziped response. check the headers sent by postman

The header in postman look likes the picture:

In Katalon, the header looks like:
Do you know how to read the gziped response?

i was facing the same issue … but the back end fixed the response from their side

I was facing the same issue - though with slightly different error message (Unrecognized token ‘é’: was expecting (JSON string, Number, Array, Object or token ‘null’, ‘true’, or ‘false’))

On the broken response header, i saw this -> Content-Encoding: br
On my request header, i had Accept-Encoding gzip, deflate, br.
I tried deleting the ‘br’ from the Accept-Encoding on my header and resent the request. It solved the issue for me.

Maybe you can try checking the Content-Encoding from the broken response and try to modify your request header’s Accept-Encoding accordingly.

I think Katalon Studio can not parse the response object with Content-Type: multipart/form-data

You had better use other tools.

1 Like