The project doesn't link with a TestOps project. Please double check and try again

Hello,
after upgrading from 7.8.2 to 8.5.1 when i try to run my tests via KRE i get error:
The project doesn’t link with a TestOps project. Please double check and try again.

It is run with the same configuration and the only thing i changed was Katalon Studio version.
Could it be that new version requires new run command or something like that or there’s a bug? Does anyone know?

Good question. Let’s see…

@vu.tran @vu.le

1 Like

my two cents, have something to do with the new platform product.
grabbing popcorn…

Response from support:

Currently, there’s a TestOps Integration mandatory when using KRE v.8.5+ onwards and we’re working on this to support KRE Standalone Edition which doesn’t require integrating TestOps. Could you please help to refer to this article to try our workaround to see how it works for you?

How to deal with the issue “The project named is required to integrate with TestOps. Please double-check and try again”?

1 Like

Well, i am using integration with TestOps by adding to command:
-orgID=***** -testOpsProjectId=***** -testOpsReleaseId=*****
I downgraded Katalon Studio to 8.4.1 and it works without problems. TestOps is getting report as well. How am i suppose to integrate with TestOps for it to work properly on 8.5.1?

It’ll likely never work in 8.5.1. Wait for 8.5.2.

Since I did not want to integrate with TestOps, I didn’t spend too much time trying to get it to work. I had an existing project that was empty - that didn’t work. I deleted the project and recreated it, but the first thing it asked for was access to source control and would not allow skipping that step. At that point, I gave up.

So, i actually made contact with Katalon Support team and they told me the same as you did, it will not work in 8.5.1. They also confirmed that it is a bug so i have to wait for the fix :stuck_out_tongue: and in the meantime i can downgrade to 8.4.1 as a workaround.
Thank you for your help :slight_smile:

the issue should be fixed in 8.5.2, this is why @Russ_Thomas posted the announcement.
give it a try.