The first release of Katalon Studio's Jenkins Plugin



Hi everyone,

We have released the first version of Jenkins Plugin for Katalon Studio. This plugin can download, deploy, and execute Katalon Studio on Jenkins servers automatically. Together with Docker-based deployment, we hope this plugin will help you apply continuous integration with Katalon Studio easily.

This version does not support Jenkins Pipeline, if you need this function please use our Docker container.

We are looking forward to your feedback and suggestions.

Plugin site:

Jenkins wiki:


Scheduled tests


not sure if i realy need it … but looks cute.
i will give a try and come back with feedback.
nice job!




I have having trouble with this. See screenshots and errors below:

I removed -runMode and -projectPath from the statement that was previously working in Jenkins (execute shell)

When I try to run the script, I get the following and the test does not execute:

Started by user MThurman
Building in workspace /Users/johnthurman/.jenkins/workspace/Product Compare
Retrieve Katalon Studio version: 5.10.1, OS: mac
Number of releases: 111
Katalon Studio is hosted at
Downloading Katalon Studio from It may take a few minutes.
at com.katalon.jenkins.plugin.KatalonUtils.downloadAndExtract(
at com.katalon.jenkins.plugin.KatalonUtils.getKatalonPackage(
at com.katalon.jenkins.plugin.ExecuteKatalonStudioTask.perform(
at hudson.tasks.BuildStepMonitor$1.perform(
at hudson.model.AbstractBuild$AbstractBuildExecution.perform(
at hudson.model.Build$
at hudson.model.Build$BuildExecution.doRun(
at hudson.model.AbstractBuild$
at hudson.model.Run.execute( at
at hudson.model.ResourceController.execute(
Finished: SUCCESS

Any ideas?



Jenkins: 2.150.1
Katalon: 5.10.1
MacOS: Mojave


Let me take a look tomorrow. Thank you for the report.


ok, thanks


Meet the same problem here. I am trying to running the code remotely on jenkins. I have put 5.10.1 and I still got the similar null pointer error


@Matt_Thurman @lexieqin Sorry for this issue. We forgot to mention in the documentation that support for macOS was not available in the first release. Version 1.0.3 with support for macOS is being published, and I will inform you when it is available.


@devalex88 Thanks!


@Matt_Thurman @lexieqin Support for macOS is now available. It only works with Katalon Studio version 5.10.1 or higher - if you want to use older versions let me know and I will upload them.


@devalex88 thanks! I will try it out later


@devalex88 Hi thanks for your fix, I saw that the studio tool get downloaded during build successfully. However there is another problem is that since we didn’t include the path in the command, there is default path for the plugin to find my project. However it didn’t work as expected. It cannot locate my project. Can you please help?


May I take a look at your build configuration?



Do you have an update on the macOS tutorial? We are beginning our process of setting up our pipeline for a mobile application. The build server is on macOS.

Thank you,


I’ve got an issue with the Jenkins plugin.

Jenkins build results in:
AppiumStartException: Appium directory is not set. Please set it in Window/Katalon Studio

Same happens when I run a Katalon test suite via cmd line (commands generated by Katalon).

When I execute the commands via cmd line from the Katalon install dir , tests do execute with success.
When executing from elsewhere (katalon home is on my PATH) I get the “Appium dir not set” error.

More details:

Note: Had 0 replies on this issue since 7 days on Github unfortunately!

Jenkins build results in: AppiumStartException: Appium directory is not set. Please set it in Window/Katalon Studio

Sorry for the late response @mdmmzm. We’ve tried to address this issue in version 1.0.8. Please let me know if it works for you.


Thank you very much for the reply.

I’ve installed 1.0.8, restarted Jenkins.
The problem still exist.


com.kms.katalon.core.exception.StepFailedException: Unable to start app at: ‘app-debug.apk’ (Root cause: com.kms.katalon.core.appium.exception.AppiumStartException: Appium directory is not set. Please set it in Window/Katalon Studio Preferences/Katalon/Mobile.)
at com.kms.katalon.core.keyword.internal.KeywordMain.stepFailed(KeywordMain.groovy:36)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:53)
at$ Source)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(
at com.kms.katalon.core.main.TestCaseExecutor.runScript(
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(
at com.kms.katalon.core.main.TestCaseExecutor.execute(
at com.kms.katalon.core.main.TestSuiteExecutor.accessTestCaseMainPhase(
at com.kms.katalon.core.main.TestSuiteExecutor.accessTestSuiteMainPhase(
at com.kms.katalon.core.main.TestSuiteExecutor.execute(
at com.kms.katalon.core.main.TestCaseMain.startTestSuite(
at com.kms.katalon.core.main.TestCaseMain$startTestSuite$ Source)

Jenkins build results in: AppiumStartException: Appium directory is not set. Please set it in Window/Katalon Studio

@ devalex88 Any chance this will be fixed soon (see my previous post)?