TestOps Executions-Re-import removes test results

Hi, I have a bug in TestOps-Test Management - Executions

Execution results “spinner” never stops, results do not appear complete. See image 1.

Attempted to complete import by clicking “re-import” and all results have disappeared. See image 2.

I also tried “completing” test run and the green check was displayed.
image

What is causing the results to not load and what should I do to correct it?
Is there a limitation on Test Set size(test count) that prevents the data from loading into TestOps?

Hi @jim.sears,

When the #330 execution ran, it updated current status of execution to TO, but didn’t submit results to TO, so when reimporting, it shows nothing here. Please run it again, if you still get this behavior, send us your katalon studio log file to investigate.

Hi Thong,

This execution is in TestOps using the CLI Katalon ‘c’ version. I don’t have a Katalon Studio log file to send you. If CLI has a log file then can you tell me where would it be?

Hi @jim.sears,

The log folder is printed in console log. Please follow the path and send us your log files.

log.zip (5.6 KB)
I have attached the requested log file. This test set is API testing and contains XML that may have broken tags, mismatches, etc. I don’t know if that affects your process for uploading results.

Another thing, the test set contains one test but it is processing 800+ rows of data for 800+ API calls. The logs are going to be long if it works correctly.

Hi KS team, I have not experienced the endless upload of test results in the last week.
If this is labelled as a bug, then it can be closed.
Jim

Hi @jim.sears

This is a known bug that causes KRE could not parse invalid XML characters in the execution0.log file and it will be fixed in v7.8.2.

Thanks for your report

Hello everyone

The issue of not being able to generate execution reports when WebUI.comment contains invalid XML characters is fixed in version 7.8.2, which is available for upgrade.

Learn more about this version.

Happy Testing

Jass

Hi @Jass, @duyluong

debug.log-NullPointer.zip (363.1 KB)

I have tried v7.8.2 and am experiencing null pointer during upload.
See attached debug.log file from TestOps execution where at the very end, upload has failed.

This log file contains xml with invalid characters (as expected) for test failures.
Jim

HI,

I am experiencing the issue still and this log might be helpful or it might be a different issue.
I upgraded to 7.9 and the latest CI package from the Katalon releases page.
I removed all existing Katalon versions and selected version 7.9 on the TestOps Plan.

The issue is that I’m using the plug-in for dynamic test set. This plugin has loaded in past executions on the TestAgent but not today. Please see log for details.

The query provider is called “built-in” (see screenshot) and is added as part of the plug-in. However, the log file states “it is not available”. The plug-in license is valid because I’m using Katalon Enterprise.

The reason I think this is related to this issue is that the results never complete loading in TestOps even though the test failed. Note the duration is 39 seconds but the test run was 15 minutes ago and the test run is still in progress. Note: I refreshed the page twice and nothing changed.

I also executed the Plan twice with the same result.

debug-MissingPlugin.log (8.7 KB)

Hi, the upload issue is spreading to other test-runs that once worked.
Do you have any update on this issue?

I found this bug listing on Katalon Github. Is this where I should look for updates?