TestCloud tunnel kt

i am using testCloud to run my test suites. My test suite should run on a certain vpn. Tried to use kt.exe tunnel.
when running kt.exe from cmd it shows starting tunnel as last execution, i dont know if tunnel is established in this case. It is stuck on starting tunnel v1.1.0…while my test suites are showing connection timeout since they can’t route to my host url which runs successfully using vpn is there any suggestions?

Can you help with this question em? Thank you

i found a way to run my kt.exe the tunnel now is established and showing

time="2022-06-30T09:28:52+03:00" level=info msg="Starting tunnel v1.1.0..."
time="2022-06-30T09:28:54+03:00" level=info msg="A new tunnel session has been created" session=74f73462
time="2022-06-30T09:28:54+03:00" level=info msg="You can start testing now. Please keep this terminal window open until you have finished your test"
time="2022-06-30T09:28:54+03:00" level=info msg="A new tunnel session has been created" session=014832e0

am not sure why 2 tunnels are established and which one is running
Anyway tried my test still tunnel cant access my forticlient vpn
@ThanhTo @vu.tran

time="2022-06-30T09:56:14+03:00" level=info msg="Tunnel session is activated" session=570e60f4
time="2022-06-30T09:56:14+03:00" level=info msg="Tunnel session is activated" session=652eb6ae
time="2022-06-30T09:56:15+03:00" level=info msg="A new tunnel session has been created" session=3b55a83d
time="2022-06-30T09:56:16+03:00" level=info msg="A new tunnel session has been created" session=1233b2df
time="2022-06-30T09:58:29+03:00" level=info msg="Tunnel session is closed" #-of-streams-processed=0 session=652eb6ae
time="2022-06-30T09:58:29+03:00" level=info msg="Tunnel session is closed" #-of-streams-processed=0 session=570e60f4

Hey @neamehbaydoun66

We have two servers in order to enable high availability for Tunnel connections. Once a tunnel is started, it makes connections to both servers. If one encounters issue then traffics will be routed to the other one, otherwise it’ll be balanced between two severs. That’s why you see two sessions in the CLI.

Our team is looking into this issue! I’ll inform you once we know anything new.

2 Likes