Test Case scripts in a folder whose name contains a dot after renaming are emptied!

## Operating System: Windows 10

## Katalon Studio Version: 5.8.6

## Katalon Studio logs: not relevant

## Environment (for Web testing): not relevant

## Environment (for Mobile testing): not relevant

## Steps to reproduce

For systematic reasons, I tried to rename a Test Case folder within Katalon Studio in such a way that its name then contained a dot (‘.’). Katalon Studio neither warned me nor prevented me from doing it.

After that I got a hint to fix errors in the script before switching to the Manual View. But I couldn’t find any such errors in the open Test Case scripts. Since I had already guessed that Katalon Studio could not handle my renaming so well, I undone my change.

So far everything seemed to be fine. Until I reopened my project and found that all my Test Cases inside the previously renamed folder were completely empty except for the import lines block!

## Expected Behavior

Katalon Studio should prevent me from renaming a Test Case folder to a name that contains a dot if it can’t handle it! Under no circumstances should Katalon Studio empty or delete any Test Case scripts!

## Actual Behavior

Katalon Studio has emptied my Test Case scripts except for the import lines block!

**## Screenshots / Videos: **not recorded

Hi Druna,

There is a warning dialog displayed when you try to include dot character on rename dialog, therefore submit button will be disabled. I’ve tried and observed this behavior. So there is no warning dialog from your side? Can you reproduce it again?


Hi Vinh,

yes, at least until the successful renaming I can reproduce the process. And there is definitely no warning, see here:

But this time it doesn’t seem to have caused any problems with my example Test Case. However, this was now very simply structured, as was the entire Test Suite.

The result after confirmation:

BTW: After my bug report yesterday, I also noticed that not only the visible Test Cases were emptied but also some other Test Cases disappeared completely - not only in the Tests Explorer within Katalon Studio, but also on the hard disk itself (in both directories, Test Cases and Scripts).

Thanks Vinh, and regards