Swipe Function Not Working After Upgrading to katalon 9.5.0(Critical Bug)

Hello Katalon Community,

I have recently upgraded to katalon 9.5.0, but the swipe function is no longer working.

I followed the solution provided in this article and installed the required versions of Appium and UIAutomator. However, the issue persists.

This is a critical bug since the new versions of Katalon are being released without fixing this basic feature. Note that the same code works perfectly in Katalon 8.6.8 with Appium version 1.21.0.

Can anyone provide assistance or suggest a workaround for this issue?

Thank you.

2 Likes

Hi there,

Thank you very much for your topic. Please note that it may take a little while before a member of our community or from Katalon team responds to you.

Thanks!

Hi there @osamazaza200, :wave:

Thank you very much for letting us know about your issue.

We will loop in our colleagues @xuan.tran (from the Studio team) and @Elly_Tran in this thread, so that they can take a look at your issue and support you better.

Thanks!

1 Like

Could you please list out the version of Appium, UIAutomator and which application you see it doesn’t work?

2 Likes

Dear @phong.nguyen,

Appium version: 2.5.1
UIAutomationVersion: uiautomator2@2.45.1
Application: home page that has scrolling view.
As mentioned the swipe function works well in that page in katalon version 8.6.8.

1 Like

It is so weird, I tried with my laptop and saw it works. Could you tell us more?The swipe function throws out error in LogViewer or it is passed but the screen was not swipe at all?
Could you increase the distance between start point and end point?

Dear the issue is not related for distance.
the issue for katalon 9Vs are not stable and need to be fixed by dev team.