Spy Web - Record Web does not work with FireFox


#1

Hi Everyone!

I am new to Katalon, just downloaded it on a virtual machine (Windows 10 x64).
I have Java JDK 10, fresh installed.

I try to open the default url with Spy Web (http://demoaut.katalon.com/) using Firefox and I got an error message

Website is opened in the background.

When I try to use Record Web, the same error occurs when I stop the recording.

Is it only me? :slight_smile:

BR
Gabor

grafik.png


#2

I am also experiencing this issue.


#3

Which version of Firefox are you using on your virtual machine? Firefox 56+ is required

https://docs.katalon.com/display/KD/Supported+Environments


#4

Iโ€™m running Firefox Quantum v. 60.0.2


#5

I am also experiencing this issue. I cannot use Firefox with record web or spy web. I am using the same version as stated above. v. 60.0.2


#6

I too am having this problem. I cannot record in Firefox (same version listed above by other users) or in Chrome.


#7

Please help to post Katalon Studio logs: https://forum.katalon.com/discussion/4405/read-this-first-before-reporting-an-issue-bug#latest

## Katalon Studio logs:

Windows (\config\.metadata\.log):

MacOS (file:///Applications/Katalon%20Studio.app/Contents/MacOS/config/.metadata/.plugins/org.eclipse.ui.workbench/log)


#8

Attached is the log file following these steps:

On Windows 10
Katalon Studio v. 5.4.2 Build 1
Firefox v. 60.0.2

1. open spy web
2. select firefox and run
3. try to record element
4. close spy web window
5. receive empty error window

.log


#9

Same issue as Shanna Long here too.

Futhermore with chrome when i record an element the marker flash green but nothing is recorded in the spy web / recorder window.

There is no log for this behaviour in my project


#10

media said:

Same issue as Shanna Long here too.

Futhermore with chrome when i record an element the marker flash green but nothing is recorded in the spy web / recorder window.

There is no log for this behaviour in my project

Media I see that as well if I do not have the Chrome browser in focus. If I click into the area that I am trying to record the objects in and then โ€˜markโ€™ them it captures just fine. Maybe this is the issue you are seeing with Chrome?

I have verified that this is definitely NOT the issue in Firefox. If someone has any advice or a solution please advise.


#11

Shanna Long said:

Media I see that as well if I do not have the Chrome browser in focus. If I click into the area that I am trying to record the objects in and then โ€˜markโ€™ them it captures just fine. Maybe this is the issue you are seeing with Chrome?

If i donโ€™t have the focus on the chrome window when i hit the mark shortcut the marker stay red without flashing.

When i got the focus, the marker flash green but nothing is capture in the spy web window.

I think there is a dependency for using the spy web and recorder tool.

On my laptop everything run smoothly with katalon studio x64 5.3.0 / 5.3.1 / 5.4.2.

On the desktop and laptop of my trainee, i got the issues described before with katalon studio x64 5.3.0 / 5.3.1 / 5.4.2.


#12

Vinh Nguyen said:

Please help to post Katalon Studio logs: https://forum.katalon.com/discussion/4405/read-this-first-before-reporting-an-issue-bug#latest

## Katalon Studio logs:

Windows (\config\.metadata\.log):

MacOS (file:///Applications/Katalon%20Studio.app/Contents/MacOS/config/.metadata/.plugins/org.eclipse.ui.workbench/log)

I have attached the log as recommended, but have had no progress on finding a solution. Can someone please advise?


#13

Hi , I have faced same issue using Katalon studio version 5.8, spy web utility does not work using (Alt+โ€™) function.

## Operating System: Windows 10

## Katalon Studio Version:5.8

**## Environment (for Web testing):**Chrome and Browser version:69.0.3497.100

Waiting your kindly feedback.
Thanks.


#14

Still facing issue with spy and record for Firefox and Chrome
also, nothing is captured for me