Some test suites absent from test results


#1

Recently when I run a test suite collection not all test suites are being logged when I view the test results. I can see that they do run when I look at the slack integration but for some reason they are absent from the results on Katalon Analytics. I have tried the re-import command for the test run but even that won’t pull in the absent test suites. The only change I have made recently was to send report emails on failure, the issue is happening whether Katalon is run via console or when I manually trigger the test suite collection


#2

I’m seeing the same thing as cavap, looks like it started around 4am EST today (I have a test suite that runs hourly).


#3

Hello,
I think I have the same issue with Katalon Analytics:

During the test the report updates automatically (ID 17). But when the test is over, there is nothing (ID 15 and 13). The status also remains locked in loading.
In my console logs, I see this:


#4

This now appears to have been corrected - I’m seeing all expected test results come through in the Analytics UI.


#5

Looks like this issue started again around 4am EST today - not seeing the full test suite results in Analytics.


#6

Can confirm that the issue has re-appeared, there doesn’t appear to be a pattern to which test suites get excluded


#7

Anyone else still having this issue?


#8

The past two days have been experiencing this issue again, all the tests suites are running but only a few are being imported to katalon analytics


#9

I am facing the same problem for the past few days.


#10

Hi @cavap, @Jason_Roberts, @jpbourdais, and @Anita

It would be helpful for us to investigate if you can confirm whether you still have the same issue.

Thank you,

Jass


#11

I’ve been getting the expected test suites returned for the past week it looks like, will let you know if the issue arises again


#12

All has been ok for the past couple of weeks.


#13

This issue is back for me as of this morning sometime around 10am EST - I have an hourly test suite collection that runs, and some of the test results are missing in Analytics with each run.


#14

The issue appears to have corrected itself of about 10am EST this morning. Odd.


#15

Had the same problem today. I ran a total of 10 tests, which also went through. Analytics often shows less.


#16

It’s back for me again too. It seems to be intermittent - of 13 tests total, Analytics has a couple or three missing every few runs, with no discernible pattern as to any particular test / test suites.


#17

This is still an intermittent issue for me. Anyone else?

Any feedback, Katalon Dev folks?