Single quotes are getting added extra when we get the data from the data file

I am fetching the test data from the excel file and binding it to API Request.

In Console when we see the data in console, we are getting the data in Single quotes and the same is getting passed to the variable and we are getting “file not found exception”(this is happening in 6.3.3 version). Please see the screenshot below.

My Guess is like in the recent implementation of “Bind test case to String” option in data file we are getting this issue and unchecked the checkbox and also tried. But still, we are getting the same error.

When I execute the same test case in 6.1.0 version, this is getting success and there are no quotes available in the console as well. Please see the screenshot. Please help!!!

Hi @Sudheer_D_J

This issue has been fixed in 6.3.4 and 7.0.0, please try to use either of these versions to see if it persists.

Thanks @Thanh When we click on Check on Updates under Help it says Upto date.

When are we getting this update??

Hi @Sudheer_D_J

Please refer to this: