Setting up OAuth2.0 authentication issues for REST calls

I’m importing some endpoints from SoapUI that use OAuth 2 authorization. so the OAuth 2 flow is Resource Owner Password Credentials Grant and it has the following fields provided
Resource Owner Name
Resource Owner Password
Client Identification
Client Secret
Access Token URL

I tried recreating the following endpoint in Katalon and the fields for OAuth 2.0 does not match the SoapUI config 1 to 1. Can someone please assist how to set up the authorization with the fields I just provided. Thanks

1 Like

Hii Milad,

You can refer Authorization OAuth document which Katalon Docs has provided.
Authorization OAuth 2.0 in Katalon Studio | Katalon Docs

1 Like

Thank you @bhavesh.maru , I have tried setting up the data using the documentation but it’s not retrieving the token when I try to request the token. Is there another way set up the Oauth 2.0 Client Credentials via a script maybe?

Hi Bhavesh, I have entered the all details like authentcation type, call back url, authtoken etc and generated token and refresh token. But when reopen the repository agian all details are wiped out. Could you please tell me any solution for this?

What do you mean by “reopen the repository”?

I guess,

  1. you use a remote git repository hosting service (GitHub, GitLab, Azure DevOps, etc). You have a repository hosted there.

  2. Once you cloned the repository into your local machine where you added some new codes.

  3. But you did NOT “push” the change to the remote repository. Therefore the remote repository does not record your recent updates at all.

  4. Next, you cloned the remote repository newly into your local PC. You found that the project does not contain the changes you recently made. And you got surprised, saying

This observation is not correct. You just forgot to “push” the change from the local machine to the remote repository. That’s all.

Perhaps you want read a good book to learn the basics of Git:

No. Others can not help you much. You need to help yourself.

If you have a backup of the newly developed codes, you can copy & pasted them into the newly cloned local repository.

If you have no backup of the newly developed codes = you have lost them entirely, then you need to type the code again from scratch.

This question is not at all related to GIT or remote repository. sorry my bad if question does not understand. Please see the below is my actual question.

  • Navigated to Object repository in Katalon studio and created one GET request
  • Enter below all details related to authorization under authorization tab
    • Type as OAuth 2.0 and all details as show in below screen shot and generated the
      Access Token and Refresh Token

  • Click on update to Http header button
  • Bearer token updated in HTTP header tab and able sent request successfully
    Notice: 1: Here Token expires in 1 day, so next day when i send request again it is giving 403 Forbidden responses as i am expecting valid response because refresh token should work when current one expires
    Notice: 2
  • I have closed GET request and reopened again it showing as below screen instead of my all details and previous entered details are not showing in Authorization tab.

How do i send request without entering all details again?.

Any update on this kindly give me solution please