setText method throws ElementNotInteractable exception

I tried to set text of field with following code, with use of setText() method:

WebUI.setText(findTestObject('Object Repository/myobj121'), findTestData('mydbfile').getValue('c10', i))

It reads textual data from given file, but I got error message:

Caused by: org.openqa.selenium.ElementNotInteractableException: element not interactable

After that I tried to use executeJavaScript() method:

WebElement element = WebUiCommonHelper.findWebElement(findTestObject('Object Repository/myobj121'),30)
WebUI.executeJavaScript("arguments[0].setAttribute('value','" + findTestData('mydbfile').getValue('c10', i) + "')")

It gives following error message:

groovy.lang.MissingMethodException: No signature of method: static com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.executeJavaScript() is applicable for argument types: (java.lang.String) values: [arguments[0].setAttribute(‘value’,‘MyValue1’)]

TestObject to = findTestObject("Object Repository/myobj121")
WebElement element = WebUiCommonHelper.findWebElement(to, 30)
String value = findTestData("mydbfile").getValue("c10", i)
String js = "arguments[0].value = '${value}';"
WebUI.executeJavaScript(js, Arrays.asList(element))

Execution is successful, but text isn’t present in field.


debug where the tetx is

I get back value, which should be pasted into input field on console.


input field on console???
are you trying to add value to some console window or what you are doing

So, input field is in browser, but value, which needs to be pasted in that field, appears on Katalon Studio concole in that form:

10-18-2019 08:41:41 DE executeJavaScript(js, Arrays.asList(element))

Elapsed time: 0,038s

Execute JavaScript ‘arguments[0].value = ‘MyValue’;’ successfully