Screen locks up in Linux Version

I have been creating tests on a windows platform but eventually they need to be run in docker containers in Linux. I set up the Katalon Linux version 6.1.1-1ed8a6dfb and migrated my projects to the Linux environment that I had successfully developed in the windows environment version 6.0.5 build 4

Once I got on a machine with enough space, everything seems to work except for one thing.
When I click on an item to get a drop down in order to changed the item - for instance to change a click to a delay, the entire application locks up. I have not been able to use the drop downs, I have to copy some other line with the item I want and then move and delete to accomplish this task.

I am not able to attach a screen print for some reason but it just is a locked drop down and nothing else works until I close the entire application with control C.

Also - If I try moving the window - the drop down stays on top and in place.
This is stopping any development in Linux at this point.
Debbie Johnson
Virginia Tech

Could you please send us the log?

Hi, I am not sure what log there is but if you let me know how to get it I’ll send it - here are screen prints, The only way I can get out of the screen is to control C
Here is what happens when I attempt to move the main screen - the pop up will not move or close.

I do not know how to get a log of this but in the meantime I installed on a new machine and I get the same error but now if I click and hold on the element I got what I thought was a black box but there is actually black print in the box. I highlighted and copied:
@CompileStatic@com.kms.katalon.core.annotation.Keyword(keywordObject = StringConstants.KW_CATEGORIZE_ELEMENT)static void click(com.kms.katalon.core.testobject.TestObject to, com.kms.katalon.core.model.FailureHandling flowControl)
Click on the given element
to - represent a web element

Hi @Debra_Johnson,

Katalon Studio currently supports GTK 2 only so please export these parameters to prevent the above issue:

  • Solution 1:
export SWT_WEBKIT2=1
export SWT_GTK3=0

and reopen Katalon Studio

  • Solution 2:
    Open katalon.ini file and add this param before --launcher.library:

and reopen Katalon Studio

Thank you very much! This worked.