Runtime Agent Error 403 occurs after 1hour of test

Hi, i have this issue, the error in my runtime agent errorLog “[ERROR] katalon - { message: ‘Request failed with status code 403’,…” which occurs after 1 hour of running test cases. My script takes about 2 hours.
Does my agent is blocked by amazon firewall after a few requests? Or something else?
Here my app log app - Copie.log (207.8 KB)

The HTTP 403 is an HTTP status code meaning access to the requested resource is forbidden. The server understood the request, but will not fulfill it.

Perhaps, the cookie expired in 1 hour. Perhaps, in the cookie stored the “your login session”.

Does your script runs 2 hours without interacting with the URL? Then certainly the session will expire in 1 hour. ---- in this case, how about getting the URL sometimes in 1 hour so that the cookie is refreshed and the session is kept alive?

Thanks, I think you are right. I do not interact with the url. I will run my script several times. It’s a loop where a pipeline file is read, I can reduce its execution time by launching it in several times. I will give a feedback asap.

The solution to my problem is simpler than expected: the default timeout is 60 minutes (in advanced settings) for tests scheduled from testops…

I didn’t have this problem when i launch the test suite from my Katalon Studio.
Thanks @kazurayam for your help.

This doesn’t work for me and my tests are correctly configured with over 1h limit (120 minutes to be exact). And I start getting the 403 errors after exactly 1 hour. I have just tried to change the time limit and re-save the configuration to see if that changes anything

Hi, try to :

  • rename your TS or TSC from Studio,
  • save and upload the new script to testops,
  • edit advanced settings on testops (set 120 minutes in Timeout field), save,
  • from your Agent machine, launch your script command with the new name of the TS.

It seems that updating the Katalon Agent to the latest fixed the problem